Bug 982955 - Task List: Task order is shuffled unpredictably after some task action is performed (claim/release/start etc.)
Task List: Task order is shuffled unpredictably after some task action is per...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium
: ER5
: 6.0.0
Assigned To: Mauricio Salatino
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 04:21 EDT by Jan Hrcek
Modified: 2014-08-06 16:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hrcek 2013-07-10 04:21:58 EDT
Description of problem:
When you have several tasks in a list (in both Grid and Day/Week wiews) and you perform actions on those tasks, the task list gets reorganized chaotically after each action.
This is confusing for end users (because task list changes under their hands - the task they perform action on can even disappear to a different page of a list) AND it makes test aumotation harder (because each time I perform an action on task in UI I have to reinitialize my selenium based representation of the task list).

Version-Release number of selected component (if applicable):
6.0.0.Beta5

How reproducible:
Always

Steps to Reproduce:

1. Go to Tasks > Tasks List
2. Create 3 or more new tasks using New Task
3. Try various actions (release / start / claim / release) on various actions and observer, how the task list gets shuffled

Actual results:
The task order is changed unpredictably in the list. When more than 10 tasks are added (i.e. task list is split into separate pages with groups of 10) the task that the action was performed on can even disappear to different page.

Expected results:
In Ideal case, when no sort order of task list is selected (by clicking on task list headers) the sort order of tasks should remain constant. For example after clicking on "release" the task list should change as little as possible (just change of field "status", and change of icon in "Actions" column.

Additional info:
Comment 1 Mauricio Salatino 2013-08-28 12:11:51 EDT
Fixed in master: http://github.com/droolsjbpm/jbpm/commit/9e31f3149
Comment 5 Zuzana Krejčová 2013-10-21 06:07:15 EDT
The commit apparently didn't make it into the product.
Comment 6 Mauricio Salatino 2013-11-20 12:58:58 EST
Ok, now the commit is in 6.0.x -> https://github.com/droolsjbpm/jbpm/commit/b7f8b3bd9f316e8f66a7254edd2462e4bfa3ebd6
Comment 7 Jan Hrcek 2013-12-05 01:21:15 EST
Ok, verified with BPMS 6.0.0 ER5.

Note You need to log in before you can comment on or make changes to this bug.