Bug 982973 - [RFE] Should add icons/scroll bar to support enter ending/beginning of the page directly in support menu
[RFE] Should add icons/scroll bar to support enter ending/beginning of the pa...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Ryan Barry
Virtualization Bugs
node
: FutureFeature, Reopened
: 1083420 (view as bug list)
Depends On:
Blocks: 1092890
  Show dependency treegraph
 
Reported: 2013-07-10 04:58 EDT by wanghui
Modified: 2016-02-10 15:11 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1092890 (view as bug list)
Environment:
Last Closed: 2015-09-17 11:00:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sherold: Triaged+


Attachments (Terms of Use)

  None (edit)
Description wanghui 2013-07-10 04:58:34 EDT
Description of problem:
When check some informations in support menu, there is so many infos in some log file. It should be more convenient to add icons/scroll bar to support enter the ending/beginning/middle of the page. 

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1718.el6
ovirt-node-3.0.0-2.999.20130708020233git0792892.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Enter F8 in Status page.
2. Select one of log file.


Actual results:
After step2, it is not so convenient if you want to see the middle/ending of the logfiles when it has so much lines. For example, the /var/log/messages have 24016 lines, and I want to see the ending messages. I have to enter 'PaDn' button so many times.

Expected results:
It should be more convenient to add icons/scroll bar to support enter the ending/beginning/middle of the page. 

Additional info:
Comment 2 Ryan Barry 2013-08-09 14:29:28 EDT
It's unlikely that this will make 6.5. urwid does not support scrollbars natively (we wrote our own), though it's a possible feature for 6.6.
Comment 3 Mike Burns 2013-08-15 10:23:52 EDT
defer to 6.6
Comment 5 Martin Pavlik 2014-04-03 06:50:00 EDT
Some thoughts on improvement

-File opens in its end
-Some hotkey which would jump to next/previous word like an ERROR or WARNING would be appropriate.
Comment 6 Martin Pavlik 2014-04-03 06:50:28 EDT
*** Bug 1083420 has been marked as a duplicate of this bug. ***
Comment 7 Ryan Barry 2014-04-03 10:29:11 EDT
Starting at the end would be relatively easy, but jumping to words like "ERROR or WARNING" is likely to be problematic, and, in my view, makes too many assumptions about what the user may be looking for beyond any technical details of the implementation.
Comment 9 Martin Pavlik 2014-07-10 09:09:03 EDT
BZ is still valid for 3.5

to sum it up:

- display relevant log files from the end (newest events)
- enable mouse support for scrolling through the log (at least make scrolling arrows clickable)
- enable searching the log through TUI
Comment 10 Ryan Barry 2014-07-10 09:42:35 EDT
Display from the end should be doable.

Searching may be possible, but I'm hesitant to implement anything but the very simplest less|more-like search semantics, since users can always drop to a shell and use more appropriate tools if they need more complex options.

The scrolling arrows are glyphs painted on the screen. urwid doesn't actually have support for scrollbars, so this is something we've added. Of the requests, this is least likely, if only because working with the bare curses layer to figure out whether this column/row actually contains the scrollbar knob or arrows would almost certainly require patching urwid itself.
Comment 11 Fabian Deutsch 2014-07-16 06:32:32 EDT
Looking at comment 9, I really wonder if we should not go back to using less for displaying logs.

It is
performing better, supports searching, and probably - if the term supports it - also scrolling using the mouse buttons.

Implementing the requested features is non trivial and will take some time, for a bug that is mainly UX related.
Comment 13 Fabian Deutsch 2015-09-17 11:00:09 EDT
This functionality will move to cockpit, where this bug does not apply anymore.

Note You need to log in before you can comment on or make changes to this bug.