This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 983009 - mpathconf fails to reload multipathd
mpathconf fails to reload multipathd
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: LVM and device-mapper development team
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 05:40 EDT by Peijun Wu
Modified: 2013-09-30 19:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-02 04:16:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peijun Wu 2013-07-10 05:40:42 EDT
Description of problem:


Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.9-53.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. mpathconf --enable --user_friendly_names y --find_multipaths y --with_multipathd y

2. multipathd show config|grep find_mul
> find_multipaths yes

3. mpathconf --enable --user_friendly_names y --find_multipaths n --with_multipathd y

4. multipathd show config|grep find_mul
> find_multipaths yes

Actual results:
value of find_multipaths haven't be changed

Expected results:
find_multipaths is set to No

Additional info:
logical error in the mpathconf scipt:
elif [ -n "$CHANGED_CONFIG" -a "$HAVE_MULTIPATHD" = 1 ]; then
        systemctl reload multipathd.service
fi
Comment 2 Xiaowei Li 2013-08-02 04:16:34 EDT
checked the mpathconf command.

"mpathconf --with_multipathd y --user_friendly_names y" could revise the multipath.conf and issue the multipathd reconfig. 

so this is not a bug.

Note You need to log in before you can comment on or make changes to this bug.