Bug 983019 - [RFE] add support for disabling spice agent based file transfer support
[RFE] add support for disabling spice agent based file transfer support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.2.0
Unspecified Unspecified
medium Severity medium
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Francesco Romani
sefi litmanovich
: FutureFeature
Depends On: 983018 1082479
Blocks: 1302542
  Show dependency treegraph
 
Reported: 2013-07-10 06:02 EDT by Hans de Goede
Modified: 2016-03-09 15:31 EST (History)
10 users (show)

See Also:
Fixed In Version: 3.6.0-10
Doc Type: Enhancement
Doc Text:
Previously, there was no way to disable the file transfer feature supported by the SPICE console. In this release, the feature can be disabled on a per virtual machine basis from the Administration Portal.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 15:31:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sherold: Triaged+


Attachments (Terms of Use)
engine + vdsm logs and vm dumpxml (820.52 KB, application/x-gzip)
2015-07-30 04:59 EDT, sefi litmanovich
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 23270 master ABANDONED vm: spice support to agent file transfer disable Never
oVirt gerrit 26917 master MERGED spice: allow to disable the agent file transfer Never
oVirt gerrit 42038 master MERGED core: SPICE copyPaste/fileTransfer not passed properly Never
oVirt gerrit 44313 None None None Never
oVirt gerrit 44815 ovirt-engine-3.6 MERGED core: translate vm graphic settings in specParams Never

  None (edit)
Description Hans de Goede 2013-07-10 06:02:52 EDT
Starting with RHEL-6.5 spice-vdagent & virt-viewer, spice has agent based file transfer support. In some environments there might be a desire to turn this off.

In order to facilitate this qemu in RHEL-6.5 will have a new -spice option called disable-agent-file-xfer, see bug 961850. Adding support for this new qemu option to libvirt is tracked in bug 983018.

This bug is for tracking adding support for this to RHEV-M.
Comment 2 Francesco Romani 2014-01-15 12:35:04 EST
libvirt still lacks support for this option. Patch for libvirt posted on libvir-list on January, 2 and under review; should be merged in libvirt 1.2.2.
Comment 11 sefi litmanovich 2015-05-28 12:07:35 EDT
Hi I wasn't able to verify this RFE on:
ovirt-engine-3.6.0-0.0.master.20150519172219.git9a2e2b3.el6.noarch

steps:
1. create vm
2. start vm with "Enable SPICE file transfer" checked to test sanity.
3. in vdsm.log under VM.create didn't see  fileTransferEnable=false parameter as expeceted.
4. stoped vm.
5. edited vm and unchecked "Enable SPICE file transfer" to disable file transfer.
6. start vm.

result:
under VM.create parameter or when dumping the libvirt xml for the vm couldn't see the fileTransferEnable=false as expected.
Comment 12 Francesco Romani 2015-05-29 02:30:36 EDT
Probably broken by https://gerrit.ovirt.org/#/c/30837/
Comment 13 Tomas Jelinek 2015-06-08 07:08:46 EDT
@Francesco: indeed - the problem is in VmInfoBuilderBase does not check if the SPICE device is there but if there are graphics infos (e.g. for infos about IP, port etc) which is available only after VM starts. And that is too late since we are just about to start the VM. Preparing a patch for it.
Comment 14 Francesco Romani 2015-06-08 07:33:10 EDT
(In reply to Tomas Jelinek from comment #13)
> @Francesco: indeed - the problem is in VmInfoBuilderBase does not check if
> the SPICE device is there but if there are graphics infos (e.g. for infos
> about IP, port etc) which is available only after VM starts. And that is too
> late since we are just about to start the VM. Preparing a patch for it.

Thanks a lot Tomas! I was out of date with the last changes, and I was about to ask some advice, but you were faster :)
Comment 15 Max Kovgan 2015-06-28 10:12:22 EDT
ovirt-3.6.0-3 release
Comment 16 sefi litmanovich 2015-07-30 04:58:49 EDT
Failed to verify with 3.6.0-4: 
ovirt-engine-3.6.0-0.0.master.20150726172446.git65db93d.el6.noarch.

same flow as in comment 11. after unchecking file transfer in vm->console menu, restarting the vm, drag and drop file worked.

attaching a tar with engine + vdsm log and vm's dumpxml after disabling file transfer.
Comment 17 sefi litmanovich 2015-07-30 04:59:53 EDT
Created attachment 1057563 [details]
engine + vdsm logs and vm dumpxml
Comment 18 Francesco Romani 2015-08-03 07:40:16 EDT
(In reply to sefi litmanovich from comment #16)
> Failed to verify with 3.6.0-4: 
> ovirt-engine-3.6.0-0.0.master.20150726172446.git65db93d.el6.noarch.
> 
> same flow as in comment 11. after unchecking file transfer in vm->console
> menu, restarting the vm, drag and drop file worked.
> 
> attaching a tar with engine + vdsm log and vm's dumpxml after disabling file
> transfer.

Thanks for finding this out! The problem here is that Engine is sending per-vm options, while VDSM is expecting the parameters inside the devices specParams.

To put it differently,
VDSM works the new way, Engine works the old way. Patch is ongoing.
Comment 19 Francesco Romani 2015-08-17 04:07:56 EDT
fix 44815 merged on 3.6 branch
Comment 20 sefi litmanovich 2015-11-09 06:59:33 EST
Verified with rhevm-3.6.0.3-0.1.el6.noarch according to steps in comment 11 and test plan attached in tracker.

See test run to review:
https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/testrun?id=3%5F6%5FVIRT%5FDisabling%5FSPICE%5FFile%5FTransfer%5F20151109
Comment 22 errata-xmlrpc 2016-03-09 15:31:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html

Note You need to log in before you can comment on or make changes to this bug.