Bug 98304 - Update to XFree86-4.1.0-49 causes bad signal to one monitor on dual-head Matrox G450
Update to XFree86-4.1.0-49 causes bad signal to one monitor on dual-head Matr...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-30 15:16 EDT by Mike Spreitzer
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-30 17:51:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the config file that worked until today (2.20 KB, text/plain)
2003-06-30 15:17 EDT, Mike Spreitzer
no flags Details
Here is the log file produced from running that config file. (27.30 KB, text/plain)
2003-06-30 15:19 EDT, Mike Spreitzer
no flags Details

  None (edit)
Description Mike Spreitzer 2003-06-30 15:16:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.8 [en] (X11; U; Linux 2.4.20-18.7 i686)

Description of problem:
I have an IBM Intellistation M-Pro (6889-94U --- that's a not new Pentium III
box), with a Matrox Millennium G450 dual-head graphics adapter in the
AGP slot.  I use it to drive two monitors: an IBM P202 on the left, and an
IBM P260 on the right.  I configured XFree86 and the G450 to use the two
monitors as one logical surface, using Xinerama.  Each monitor runs at
1600x1200, giving me a total of 3200x1200 distinct pixels.
This has been working fine for months, since I bought the G450.
I am running RedHat Linux 7.1, updating with `up2date` occasionally.
Today I updated again, and was given new X server stuff, all of version
4.1.0-49 (along with other things, such as the 2.4.20-18.7 kernel).
After rebooting and starting X, I found the left monitor blank,
and the corresponding half of my logical surface inaccessible.
That monitor complains about the input signal being out of range.

I looked in the X server's log file, and found a complaint about DRI, so I tried
editing my X server config file to omit the DRI section; that did not solve
the problem.

Version-Release number of selected component (if applicable):
XFree86-4.1.0-49

How reproducible:
Always

Steps to Reproduce:
1.  Install G450 card.
2.  Install mgadrivers-2.1.tgz and mgapdesk-1_00_7beta_i386.rpm from Matrox.
3.  Hack up any old one-head X config, and use it to run MGA PowerDesk to create
a dual-head XFree86-4 config file.  Ignore complaint about display drivers not
being supported.  Pick dual-head "merged" config.
4.  Re-start X server.

Actual Results:  In that case, I think I got 3200x1200 pixels stuffed onto one
1600x1200 monitor via
scrolling.

Expected Results:  Two monitors running at 1600x1200 each, each displaying half
of a logical
3200x1200 surface.

Additional info:

Will attach config file & log.
Comment 1 Mike Spreitzer 2003-06-30 15:17:54 EDT
Created attachment 92692 [details]
This is the config file that worked until today
Comment 2 Mike Spreitzer 2003-06-30 15:19:00 EDT
Created attachment 92693 [details]
Here is the log file produced from running that config file.
Comment 3 Mike Spreitzer 2003-06-30 15:21:21 EDT
The XFree86 people don't want to touch this, since they do not support
4.1 (you can find this bug reported,and rejected, in their Bugzilla).
Comment 4 Mike A. Harris 2003-06-30 17:51:01 EDT
Red Hat does not support any 3rd party video drivers.  We support only the
drivers that ship with Red Hat Linux and XFree86, and only running on an official
Red Hat Linux kernel with no 3rd party kernel modules loaded.

You should contact Matrox directly for any technical support or bug reports
for the drivers they provide on their website.

Note You need to log in before you can comment on or make changes to this bug.