Bug 983051 - [RHSC] Import cluster when one of the peers is unresolvable or unreachable from the engine, fails. [NEEDINFO]
[RHSC] Import cluster when one of the peers is unresolvable or unreachable fr...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Timothy Asir
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 07:43 EDT by Shruti Sampat
Modified: 2015-05-13 12:27 EDT (History)
11 users (show)

See Also:
Fixed In Version: CB5
Doc Type: Bug Fix
Doc Text:
Previously, the Import Cluster operation was failing when one of the hosts was unreachable. Now, with this update, the Import Cluster operation is successful as the unreachable host entry is removed from the list.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:32:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sharne: needinfo? (tjeyasin)


Attachments (Terms of Use)
engine logs (178.25 KB, text/x-log)
2013-07-10 07:43 EDT, Shruti Sampat
no flags Details
vdsm logs (59.06 KB, text/x-log)
2013-07-10 07:46 EDT, Shruti Sampat
no flags Details

  None (edit)
Description Shruti Sampat 2013-07-10 07:43:26 EDT
Created attachment 771561 [details]
engine logs

Description of problem:
---------------------------------------
Server A has 2 peers, B and C.

B was peer probed from A using the IP address, C was peer probed from A, using the hostname known only among the three servers, by means of entries in /etc/hosts.

When trying to import the cluster using the Console, using the IP address of A, the import fails with the following exception - 

java_nio_channels_UnresolvedAddressException

Another case when the import fails, is when one of the hosts is down, in other words, unreachable. In this case, the import fails with the following exception-

org_apache_sshd_common_RuntimeSshException: Failed to get the session_

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.0-0.bb5.el6rhs 

How reproducible:
Always

Steps to Reproduce:
The following are the steps to reproduce the first case described above - 

1. Add entries for servers A and B in /etc/hosts of C, to identify them as host1 and host2 respectively and similar entries in A and B too.
2. Run the following on A - 

# gluster peer probe <IP-address-of-B>
# gluster peer probe host3

host3 is to identify server C.

3. Now, try to import this cluster via the Console, by providing the IP address of A, in the import cluster screen.

For the second case described above, 

1. Run 'gluster peer probe' from server A to B and C using the IP addresses of B and C.
2. Import the cluster via the Console, using the IP address of A.


Actual results:
Import fails with the above described exceptions.

Expected results:
For both the above described cases, import should succeed for those hosts that are reachable and resolvable. For others alone, it should fail.

Additional info:
Attaching engine logs and vdsm logs from server A.
Comment 1 Shruti Sampat 2013-07-10 07:46:07 EDT
Created attachment 771563 [details]
vdsm logs
Comment 3 Timothy Asir 2013-10-10 07:34:33 EDT
For Case A:
    You have to add entries in engine host file also
    Then only the engine can reach the host using the IP address 
    given in the host file.

For Case B:
    Currently the engine gets the peer status from (any of the) given
    server in the Gluster and will send a call to add them individually;
    and if any peer (server) is unreachable by the engine, it fails.

    Patch sent to ovirt-engine upstream:
    http://gerrit.ovirt.org/#/c/19614/
Comment 4 Shruti Sampat 2013-10-25 11:08:39 EDT
Verified as fixed in Red Hat Storage Console Version: 2.1.2-0.21.beta1.el6_4. Import cluster works in both cases mentioned above.
Comment 5 Shalaka 2014-01-09 00:20:04 EST
Please review the edited DocText and signoff.
Comment 6 Shalaka 2014-01-09 00:20:30 EST
Please review the edited DocText and signoff.
Comment 7 Shalaka 2014-01-09 00:20:46 EST
Please review the edited DocText and signoff.
Comment 9 errata-xmlrpc 2014-02-25 02:32:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.