Bug 983055 - Sorting with rich:column doesn't work in Metamer
Sorting with rich:column doesn't work in Metamer
Status: CLOSED NOTABUG
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: PortletBridge (Show other bugs)
6.1.0
x86_64 Linux
unspecified Severity unspecified
: ---
: 6.1.0
Assigned To: Ken Finnigan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 07:54 EDT by Petr Mensik
Modified: 2015-07-19 21:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Fedora 18, Firefox 22
Last Closed: 2013-07-16 08:57:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker RF-13088 Major Resolved Sorting with rich:column doesn't work in Metamer 2017-08-30 16:59 EDT

  None (edit)
Description Petr Mensik 2013-07-10 07:54:53 EDT
Sorting doesn't work properly on both Custom Comparator and Sorting page. If you check the ascending or descending radio button, then some sorting is applied to the list but it's definitely not in correct order. It works only if you select unsorted which will sort the list into the ascending order.

Steps to reproduce

1. Deploy Metamer app
2. Go to http://localhost:8080/metamer/faces/components/richColumn/list.xhtml
3. Try both Custom Comparator and Sorting

Document URL: 

Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

Additional information: 


Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 JBoss JIRA Server 2013-07-11 14:34:10 EDT
Brian Leathem <bleathem@gmail.com> made a comment on jira RF-13088

Do you get the behaviour you expect if you set _sortMode="single"_?
Comment 4 JBoss JIRA Server 2013-07-12 03:50:15 EDT
Petr Mensik <pmensik@redhat.com> made a comment on jira RF-13088

Nope, behaviour is still the same.
Comment 6 JBoss JIRA Server 2013-07-16 08:55:15 EDT
Petr Mensik <pmensik@redhat.com> made a comment on jira RF-13088

Sorry, my fault, I didn't notice that it's sorting by state's length and not alphabetically. {noformat} {fn:length(record.state)} {noformat}
Comment 7 JBoss JIRA Server 2013-07-16 08:55:35 EDT
Petr Mensik <pmensik@redhat.com> made a comment on jira RF-13088

Sorry, my fault, I didn't notice that it's sorting by state's length and not alphabetically, so everything is ok. {noformat} {fn:length(record.state)} {noformat}
Comment 8 JBoss JIRA Server 2013-07-16 08:56:07 EDT
Petr Mensik <pmensik@redhat.com> updated the status of jira RF-13088 to Resolved
Comment 9 JBoss JIRA Server 2013-07-16 08:56:07 EDT
Petr Mensik <pmensik@redhat.com> made a comment on jira RF-13088

Not a bug

Note You need to log in before you can comment on or make changes to this bug.