Bug 983063 - Administration / Site Redirects - Condition table is incomplete
Administration / Site Redirects - Condition table is incomplete
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Portal (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER04
: 6.1.0
Assigned To: Default User
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 08:06 EDT by Dominik Pospisil
Modified: 2013-11-07 09:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 09:21:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the site redirect conditions (39.39 KB, image/png)
2013-07-15 10:48 EDT, Matt Wringe
no flags Details
redirect overview page (174.48 KB, image/png)
2013-07-15 12:05 EDT, Dominik Pospisil
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker GTNPORTAL-3183 Major Resolved Redirect Conditions Overview page is confusing. 2013-08-21 07:01:08 EDT

  None (edit)
Description Dominik Pospisil 2013-07-10 08:06:49 EDT
Administration / Site Redirects - Condition table seems to be incomplete.

The first column show condition name and the second column shows Contain/ Does Not contain value.

However the table does not show what is the value related to - User Agent or Propery. Without this information the table does not make much sense.
Comment 2 Matt Wringe 2013-07-15 10:48:25 EDT
Created attachment 773799 [details]
Screenshot of the site redirect conditions

I am confused over why this issue has been raise. Attached is a screen shot which shows the redirect admin.

It should be clear from the screen shot that the section under 'User Agent String' contains the settings for user agent strings while the section under 'Property' handles the javascript inspected device properties.

Note: only User Agent string uses 'contains' 'does not contain', the device properties use different options. Please see the documentation.
Comment 3 Dominik Pospisil 2013-07-15 12:04:42 EDT
Hi Mat,

sorry for not being specific enough. I was referring to redirect configuration page, not property editor page.

The page shows settings only for user-agent based conditions without any indication that user-agent based condition is used. For property based, the settings column is left blank completely.
Comment 4 Dominik Pospisil 2013-07-15 12:05:43 EDT
Created attachment 773818 [details]
redirect overview page
Comment 5 Matt Wringe 2013-07-15 14:37:25 EDT
Ah, yeah, ok, makes a lot more sense now. Thanks for updating the bug with the screenshot.

Gabriel needs to make a decision on how this should be fixed (then Alex can implement the fix). Created a jira to track this on the GateIn side (GTNPORTAL-3183).
Comment 6 JBoss JIRA Server 2013-07-16 15:12:50 EDT
Gabriel Cardoso <gcardoso@redhat.com> made a comment on jira GTNPORTAL-3183

After discussing with Alexandre and Matt, we agreed on the following solution: http://statichtml-theute.rhcloud.com/cardosogabriel/gatein-client/site-redirects.html

Code is available at: https://github.com/cardosogabriel/gatein-client/commit/49e69952ad7d5a1f56838d2a8e9b9ae3bb80f4bf
Comment 7 Dominik Pospisil 2013-08-21 07:00:59 EDT
Verified (ER4).

Note You need to log in before you can comment on or make changes to this bug.