Bug 983095 - FSError: label failed
FSError: label failed
Status: CLOSED DUPLICATE of bug 1066650
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:cc3f862a8054dd0a47807b4c46d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 09:40 EDT by Jakub Dorňák
Modified: 2016-11-30 19:57 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-06 11:31:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (204.20 KB, text/plain)
2013-07-10 09:40 EDT, Jakub Dorňák
no flags Details
File: environ (440 bytes, text/plain)
2013-07-10 09:40 EDT, Jakub Dorňák
no flags Details
File: lsblk_output (5.71 KB, text/plain)
2013-07-10 09:40 EDT, Jakub Dorňák
no flags Details
File: messages (334.71 KB, text/plain)
2013-07-10 09:40 EDT, Jakub Dorňák
no flags Details
File: nmcli_dev_list (13.16 KB, text/plain)
2013-07-10 09:41 EDT, Jakub Dorňák
no flags Details
File: os_info (179 bytes, text/plain)
2013-07-10 09:41 EDT, Jakub Dorňák
no flags Details
File: program.log (92.53 KB, text/plain)
2013-07-10 09:41 EDT, Jakub Dorňák
no flags Details
File: storage.log (951.03 KB, text/plain)
2013-07-10 09:41 EDT, Jakub Dorňák
no flags Details
File: ifcfg.log (744 bytes, text/plain)
2013-07-10 09:41 EDT, Jakub Dorňák
no flags Details
File: anaconda-tb (1.54 MB, application/octet-stream)
2013-07-10 09:41 EDT, Jakub Dorňák
no flags Details
anaconda-tb-UZynDl (1.39 MB, text/plain)
2013-07-10 15:19 EDT, Steve Tyler
no flags Details
anaconda-tb-oU9VB9 (584.33 KB, text/plain)
2013-07-10 16:17 EDT, Steve Tyler
no flags Details
anaconda-tb-sHDJqw (471.89 KB, text/plain)
2013-07-10 16:33 EDT, Steve Tyler
no flags Details

  None (edit)
Description Jakub Dorňák 2013-07-10 09:40:36 EDT
Description of problem:
1. boot live CD
2. start installation
3. create custom disk layout in separate window
4. reload disk in the installation window
5. setup partitions usage (use encrypted partitions including vfat)
6. start installation
7. setup root password
8. try to create user

Version-Release number of selected component:
anaconda-19.30.13-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 652, in writeLabel
    raise FSError("label failed")
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 405, in doFormat
    self.writeLabel(self.label)
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 783, in create
    return self.doFormat(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 471, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 140, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
FSError: label failed

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-blivet-0.17-1.fc19.noarch, python-libs-2.7.5-1.fc19.x86_64
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19
Comment 1 Jakub Dorňák 2013-07-10 09:40:42 EDT
Created attachment 771608 [details]
File: anaconda.log
Comment 2 Jakub Dorňák 2013-07-10 09:40:46 EDT
Created attachment 771609 [details]
File: environ
Comment 3 Jakub Dorňák 2013-07-10 09:40:50 EDT
Created attachment 771610 [details]
File: lsblk_output
Comment 4 Jakub Dorňák 2013-07-10 09:40:56 EDT
Created attachment 771611 [details]
File: messages
Comment 5 Jakub Dorňák 2013-07-10 09:41:00 EDT
Created attachment 771612 [details]
File: nmcli_dev_list
Comment 6 Jakub Dorňák 2013-07-10 09:41:09 EDT
Created attachment 771613 [details]
File: os_info
Comment 7 Jakub Dorňák 2013-07-10 09:41:13 EDT
Created attachment 771614 [details]
File: program.log
Comment 8 Jakub Dorňák 2013-07-10 09:41:22 EDT
Created attachment 771615 [details]
File: storage.log
Comment 9 Jakub Dorňák 2013-07-10 09:41:27 EDT
Created attachment 771616 [details]
File: ifcfg.log
Comment 10 Jakub Dorňák 2013-07-10 09:41:38 EDT
Created attachment 771617 [details]
File: anaconda-tb
Comment 11 Steve Tyler 2013-07-10 15:07:47 EDT
Attempt to reproduce Bug 983095.
Exception occurred at:
Creating vfat on /dev/mapper/luks-xxxxx ...

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
package:        anaconda-19.30.13-1
product:        Fedora
reason:         FSError: label failed
release:        Cannot get release name.
version:        19
Comment 12 Steve Tyler 2013-07-10 15:19:01 EDT
Created attachment 771802 [details]
anaconda-tb-UZynDl

Log file corresponding to Comment 11.

Reproduced in a VM with:
$ qemu-kvm -m 4096 -hda f19-test-1.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on
Comment 13 Steve Tyler 2013-07-10 16:12:52 EDT
Attempt to reproduce Bug 983095.
Standard partitions.
No encryption.
/home/user with label "user" is vfat.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
package:        anaconda-19.30.13-1
product:        Fedora
reason:         FSError: label failed
release:        Cannot get release name.
version:        19
Comment 14 Steve Tyler 2013-07-10 16:17:35 EDT
Created attachment 771842 [details]
anaconda-tb-oU9VB9

Log file corresponding to Comment 13.
Comment 15 Steve Tyler 2013-07-10 16:33:56 EDT
Created attachment 771866 [details]
anaconda-tb-sHDJqw

Here is a reproducer and corresponding log file:

$ qemu-img create f19-test-1.img 16G
$ qemu-kvm -m 4096 -hda f19-test-1.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on

Select Standard Partitions.
Select "I want to review/modify ..."
Click here to create ...
Reduce Desired Capacity of "/" to 8 GB.
Click Update Settings.
Click "+" to add mount point:
  /home/user
  1 gb
Change File System to "vfat".
Set Label to "user".
Click Done.
Click Accept Changes.
Click Begin Installation.
Exception occurs at "Creating vfat on /dev/sda5":
  FSError: label failed
Comment 16 Steve Tyler 2013-07-10 16:36:07 EDT
I guess I should have looked at the log files more carefully:  :-)

20:27:30,504 INFO program: fatlabel: labels cannot contain lower case characters
Comment 17 Daniel Peess 2013-08-05 14:29:09 EDT
installer aborts as i've inserted lower case labels for dos partitions.
should handle this more gracefully... like uppercase them automatically.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Desktop-x86_64-19-1 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-blivet-0.17-1.fc19.noarch, python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         FSError: label failed
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 18 Emmett Culley 2013-09-18 15:25:58 EDT
Did custom partitioning failed as attempting to enter root password

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
package:        anaconda-19.30.13-1
product:        Fedora
reason:         FSError: label failed
release:        Cannot get release name.
version:        19
Comment 19 Emmett Culley 2013-10-08 19:30:14 EDT
Marathon installtion session!

Attempting to install on new system with win7 installed.  Tried evething to attempt install on GPT drives without EFI.  Finally ended up seeing it fail at "installing bootloader", which I have seem lots of times.

So I started over (manually partitioning drives with RAID and LVM) but this time booting into EFI.  This time it failed at "creating efi on /dev/sdb3.  And that only after going through multiple attempts to get past storage setup with the "failure to add stage1..."

Finally I tried causing the second drive to be the boot drive, and the begin installation button was finnaly enabled.  But is failed almost immediately after clicking in it.


cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 quiet
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
package:        anaconda-19.30.13-1
product:        Fedora
reason:         FSError: label failed
release:        Cannot get release name.
version:        19
Comment 20 Olen 2013-10-15 13:03:10 EDT
trying to install from fedora 19 livedvd onto dell inspiron i660-7007bk desktop windows 8.  uefi enabled.
trying to make fedora use its own efi partition, since if it shares windows like it tries to do by default, after windows
boots, it wipes out the fedora files, and only windows is there.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Desktop-x86_64-19-1 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-blivet-0.17-1.fc19.noarch, python-libs-2.7.5-1.fc19.x86_64
package:        anaconda-19.30.13-1.fc19.x86_64
packaging.log:  
product:        Fedora
reason:         FSError: label failed
release:        Fedora release 19 (Schrödinger’s Cat)
version:        19
Comment 21 mulhern 2014-03-06 11:31:08 EST

*** This bug has been marked as a duplicate of bug 1066650 ***

Note You need to log in before you can comment on or make changes to this bug.