Bug 983116 - net-snmp query fails after update to 1:5.5-44.el6_4.2
net-snmp query fails after update to 1:5.5-44.el6_4.2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: net-snmp (Show other bugs)
6.4
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jan Safranek
Dalibor Pospíšil
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 10:19 EDT by maarten
Modified: 2014-05-02 07:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The previous Net-SNMP update contained a fix to improve checking of invalid incoming SNMP messages. This fix introduced a regression and some valid SNMP messages with multiple variables inside might be marked as invalid. Consequence: Net-SNMP tools and servers might reject valid SNMP messages and wait for "proper" response until timeout. Fix: Valid SNMP messages are not rejected. Result: The servers and utilities accept first incoming message and do not wait for a timeout.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:50:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 501873 None None None Never

  None (edit)
Description maarten 2013-07-10 10:19:43 EDT
Description of problem:

after update from net-snmp  1:5.5-44.el6_4.1  to 1:5.5-44.el6_4.2

a snmp query times out



Version-Release number of selected component (if applicable): 1:5.5-44.el6_4.1/1:5.5-44.el6_4.2

How reproducible:



Steps to Reproduce:
1. yum rollback
2. test 
3. yum install, test again 

Actual results:
$ time { snmpbulkwalk -t 30  -v2c -c 'xxxxx' -m '' -M '' -Cc -On -Ob -OQ -Ot 145.92.231.151 1.3.6.1.4.1; }
.1.3.6.1.4.1.2021.2.1.1.1 = 1
[cut]
Timeout: No Response from 145.92.231.151

real	3m0.275s
user	0m0.002s
sys	0m0.003s

Expected results:
$ time { snmpbulkwalk -t 30  -v2c -c 'xxxxx' -m '' -M '' -Cc -On -Ob -OQ -Ot 145.92.231.151 1.3.6.1.4.1; }
.1.3.6.1.4.1.2021.2.1.1.1 = 1
[cut]
.1.3.6.1.4.1.8072.1.3.2.1.0 = 0

real	0m20.090s
user	0m0.488s
sys	0m0.187s



real	0m20.090s
user	0m0.488s
sys	0m0.187s


Additional info:
Comment 2 Jan Safranek 2013-08-12 08:34:34 EDT
Thanks for the report!

I've fixed it upstream in commit e41c2f574c25d8dd273f2406eeeac19bc2ae16db.
Comment 6 maarten 2013-08-16 09:10:21 EDT
Hi,

I have done the same test (snmp query) with net-snmp.x86_64              1:5.5-44.el6_4.4 and I get the same result: time out.

Regards,
Maarten
Comment 9 errata-xmlrpc 2013-11-21 17:50:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1693.html

Note You need to log in before you can comment on or make changes to this bug.