Bug 983130 - [RFE] please add information on a volume's snapshots in volume's tab
[RFE] please add information on a volume's snapshots in volume's tab
Status: CLOSED UPSTREAM
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
unspecified
x86_64 Linux
low Severity low
: ---
: 6.0 (Juno)
Assigned To: Julie Pichon
Ami Jeain
storage
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 10:57 EDT by Dafna Ron
Modified: 2015-06-04 17:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 06:44:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1190843 None None None Never
Launchpad 1323644 None None None Never

  None (edit)
Description Dafna Ron 2013-07-10 10:57:50 EDT
Description of problem:

since we cannot remove a volume while it has a snapshot it would be nice to be able to see what volume has a snapshot and which does not. 

Version-Release number of selected component (if applicable):

python-django-horizon-2013.1.2-1.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. create a volume 
2. create a snapshot 
3.

Actual results:

we can see in the images&snapshot tab what is the volume name but we cannot see any information on the snapshot from the volumes tab

Expected results:

since we cannot remove a volume that has snapshot it would be useful to show some information on the snapshot on the volumes tab. 

Additional info:
Comment 1 Julie Pichon 2013-07-17 06:44:19 EDT
Upstream is planning to move the "Volume snapshots" table to the "Volumes" panel, which should help with this.
Comment 2 Julie Pichon 2014-05-27 07:21:19 EDT
The "Volume snapshots" table was moved to the "Volumes" panel in Icehouse. This should be available in the current OSP 5 packages, and help a little with this problem. However I'm not sure if this is enough to consider the bug resolved.
Comment 3 Julie Pichon 2014-05-27 07:22:48 EDT
Hi Dafna - as per my previous comment, could you either confirm if this is enough to resolve the problem for now, or otherwise open a bug upstream to track the remaining parts? Thank you.
Comment 4 Dafna Ron 2014-05-27 07:33:20 EDT
I think that the problem is the mapping of volume snapshots. 
since snapshots are dependent on a volume I think it would be useful and time saving for an admin to see the chain. 
I don't think that moving snapshots to the volume completely solves the issue. however, I understand that it might require more work than a simple patch... maybe we should move this to RFE?
Comment 5 Julie Pichon 2014-05-27 08:31:33 EDT
Thanks for the answer, that sounds reasonable to me. I think opening a bug for this upstream would help getting it some attention as well (even if this is a RFE, I think for now it would fit upstream as a wishlist-type bug rather than full-blown blueprint).
Comment 6 Dafna Ron 2014-05-27 08:46:34 EDT
there is an upstream bug (attached in external links)
perhaps we can create a second one for showing chaining between volume and volume snapshots?
Comment 7 Julie Pichon 2014-05-27 08:48:30 EDT
The upstream bug attached is resolved and only related to moving the snapshots to the volumes panel, I agree another one should be created to address the other point.
Comment 8 Dafna Ron 2014-05-27 09:05:16 EDT
done: https://bugs.launchpad.net/horizon/+bug/1323644
Comment 9 Julie Pichon 2014-05-27 09:08:37 EDT
Thanks!
Comment 10 Julie Pichon 2014-10-14 06:44:36 EDT
Closing downstream task for low priority RFE, this is tracked upstream at https://bugs.launchpad.net/horizon/+bug/1323644

Note You need to log in before you can comment on or make changes to this bug.