This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 983142 - [abrt] telepathy-gabble-0.17.4-1.fc19: dconf_shm_open: Process /usr/libexec/telepathy-gabble was killed by signal 5 (SIGTRAP)
[abrt] telepathy-gabble-0.17.4-1.fc19: dconf_shm_open: Process /usr/libexec/t...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
abrt_hash:c1f4650e7a7aef418da5ddec291...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 11:34 EDT by Lubo
Modified: 2013-09-11 21:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-74.2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 21:53:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (32.35 KB, text/plain)
2013-07-10 11:34 EDT, Lubo
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-10 11:34 EDT, Lubo
no flags Details
File: core_backtrace (4.62 KB, text/plain)
2013-07-10 11:34 EDT, Lubo
no flags Details
File: dso_list (4.59 KB, text/plain)
2013-07-10 11:34 EDT, Lubo
no flags Details
File: environ (727 bytes, text/plain)
2013-07-10 11:34 EDT, Lubo
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-10 11:34 EDT, Lubo
no flags Details
File: maps (22.81 KB, text/plain)
2013-07-10 11:34 EDT, Lubo
no flags Details
File: open_fds (420 bytes, text/plain)
2013-07-10 11:34 EDT, Lubo
no flags Details
File: proc_pid_status (941 bytes, text/plain)
2013-07-10 11:35 EDT, Lubo
no flags Details

  None (edit)
Description Lubo 2013-07-10 11:34:28 EDT
Version-Release number of selected component:
telepathy-gabble-0.17.4-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/libexec/telepathy-gabble
crash_function: dconf_shm_open
executable:     /usr/libexec/telepathy-gabble
kernel:         3.9.9-301.fc19.x86_64
runlevel:       N 5
uid:            1000
var_log_messages: Jul 10 17:31:47 sklca abrt[11184]: Saved core dump of pid 11181 (/usr/libexec/telepathy-gabble) to /var/tmp/abrt/ccpp-2013-07-10-17:31:47-11181 (19193856 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 dconf_shm_open at dconf-shm.c:87
 #3 dconf_engine_source_user_reopen at dconf-engine-source-user.c:76
 #4 dconf_engine_source_refresh at dconf-engine-source.c:57
 #5 dconf_engine_acquire_sources at dconf-engine.c:201
 #6 dconf_engine_get_state at dconf-engine.c:311
 #7 dconf_engine_watch_fast at dconf-engine.c:762
 #9 g_object_new_valist at gobject.c:1836
 #11 g_settings_new at gsettings.c:869
 #12 g_proxy_resolver_gnome_init at gproxyresolvergnome.c:157
 #13 g_type_create_instance at gtype.c:1917

Potential duplicate: bug 901552
Comment 1 Lubo 2013-07-10 11:34:35 EDT
Created attachment 771699 [details]
File: backtrace
Comment 2 Lubo 2013-07-10 11:34:38 EDT
Created attachment 771700 [details]
File: cgroup
Comment 3 Lubo 2013-07-10 11:34:41 EDT
Created attachment 771701 [details]
File: core_backtrace
Comment 4 Lubo 2013-07-10 11:34:44 EDT
Created attachment 771702 [details]
File: dso_list
Comment 5 Lubo 2013-07-10 11:34:47 EDT
Created attachment 771703 [details]
File: environ
Comment 6 Lubo 2013-07-10 11:34:50 EDT
Created attachment 771704 [details]
File: limits
Comment 7 Lubo 2013-07-10 11:34:54 EDT
Created attachment 771705 [details]
File: maps
Comment 8 Lubo 2013-07-10 11:34:58 EDT
Created attachment 771706 [details]
File: open_fds
Comment 9 Lubo 2013-07-10 11:35:01 EDT
Created attachment 771707 [details]
File: proc_pid_status
Comment 10 Michael Scherer 2013-08-04 14:46:00 EDT
juste starting empathy caused the crash

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/libexec/telepathy-gabble
crash_function: dconf_shm_open
executable:     /usr/libexec/telepathy-gabble
kernel:         3.10.4-300.fc19.x86_64
package:        telepathy-gabble-0.17.5-2.fc19
reason:         Process /usr/libexec/telepathy-gabble was killed by signal 5 (SIGTRAP)
runlevel:       N 5
uid:            500
Comment 11 Shawn Q 2013-08-14 11:07:29 EDT
Just opened the program, I'm not sure if it restarted itself, but it did open.

Something strange happened before this, though, I had performed fedora-upgrade to go from 18 to 19, following all the usual safety steps.  

There were a couple of orphaned rpm's, nothing serious though, netbeans, some old kernels.  I rebooted, everything was running great, no complaints in /var/log/messages during boot time, then maybe an hour later, environment completely locked up.  

I was able to hit Num Lock on the keyboard and see the light turn on and off, but switching console via CTRL-ALT-F2 / etc. did not work, and SysRq combo "REISUB" did not do anything.  

Had to resort to a hard power cycle, and during boot time I'm noticing a couple of strange entries in /var/log/messages:


Before issue:

Aug 14 10:33:32 node159 dbus[487]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Aug 14 10:33:32 node159 dbus-daemon[487]: no kernel backlight interface found
Aug 14 10:33:32 node159 dbus-daemon[487]: dbus[487]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Aug 14 10:33:32 node159 dbus[487]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Aug 14 10:38:19 node159 dbus-daemon[487]: dbus[487]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Aug 14 10:38:19 node159 dbus-daemon[487]: no kernel backlight interface found
Aug 14 10:38:19 node159 dbus-daemon[487]: dbus[487]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Aug 14 10:38:19 node159 dbus[487]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Aug 14 10:38:19 node159 dbus[487]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Aug 14 10:42:58 node159 systemd[1]: Starting Getty on tty2...
\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00Aug 14 10:45:31 node159 rsyslogd: [origin software="rsyslogd" swVersion="7.2.6" x-pid="485" x-info="http://www.rsyslog.com"] start

Note the \00\00\00 in the log here, these are invalid special characters during th etime the system locked up.

After boot:

Aug 14 10:46:26 node159 dbus[486]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'
Aug 14 10:46:26 node159 dbus[486]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.nm-dispatcher.service': Unit dbus-org.freedesktop.nm-dispatcher.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.nm-dispatcher.service' for details.
Aug 14 10:46:26 node159 NetworkManager[589]: <warn> Dispatcher failed: (32) Unit dbus-org.freedesktop.nm-dispatcher.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.nm-dispatcher.service' for details.

Looking at systemctl, this nm-dispatcher service is legitimately missing...not sure what happened with it.

Lastly, opening something as simple as gedit via konsole shows:

(gedit:1598): dconf-CRITICAL **: unable to create file '/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.

I know this isn't specific to telepathy, I think, but in case it is and there's bigger problems as a source, I felt you should know.


reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/libexec/telepathy-gabble
crash_function: dconf_shm_open
executable:     /usr/libexec/telepathy-gabble
kernel:         3.10.5-201.fc19.x86_64
package:        telepathy-gabble-0.17.5-2.fc19
reason:         Process /usr/libexec/telepathy-gabble was killed by signal 5 (SIGTRAP)
runlevel:       N 5
uid:            1000
Comment 12 Michael Scherer 2013-08-28 19:26:00 EDT
Ok, I finally found the problem :

type=AVC msg=audit(1377732106.491:894): avc:  denied  { getattr } for  pid=23892 comm="telepathy-gabbl" path="/run/user" dev="tmpfs" ino=15266 scontext=staff_u:staff_r:telepathy_gabble_t:s0-s0:c0.c1023 tcontext=system_u:object_r:user_tmp_t:s0 tclass=dir

running empathy with a confined user break , with the message seen before.

using setenfoce 0 make it work, and semodule -DB show me this avc.

Since the error is basically gabble cannot opening /run/user, i assume that either :
- a access that should be given to telepathy_gabble_t, 
- a bug in dconf.

Assigning to selinux, as I think the access is kinda needed.
Comment 13 Daniel Walsh 2013-08-29 08:29:23 EDT
575e5d0cca89268c98ee5132441e2192d7059409 fixes this in git.
Comment 14 Miroslav Grepl 2013-09-02 09:59:24 EDT
Back ported.
Comment 15 Fedora Update System 2013-09-09 03:54:42 EDT
selinux-policy-3.12.1-74.2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-74.2.fc19
Comment 16 Fedora Update System 2013-09-09 19:57:39 EDT
Package selinux-policy-3.12.1-74.2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-74.2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16231/selinux-policy-3.12.1-74.2.fc19
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2013-09-11 21:53:53 EDT
selinux-policy-3.12.1-74.2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.