Bug 983216 - jbossews build artifacts aren't synced to scaled gears due to mv operation during deploy
jbossews build artifacts aren't synced to scaled gears due to mv operation du...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
:
: 983494 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 13:49 EDT by Dan Mace
Modified: 2015-05-14 19:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 11:23:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Mace 2013-07-10 13:49:09 EDT
Description of problem:

The jbossews `control deploy` implementation uses a `mv` operation to relocate built artifacts from $OPENSHIFT_REPO_DIR to the live Tomcat deployments directory. During scale up events and scaled builds, only directories relative to $OPENSHIFT_REPO_DIR are synced. Scaled gears thus do not receive the built artifacts.

Version-Release number of selected component (if applicable):


How reproducible:

Perform a build in a scalable jbossews application.


Steps to Reproduce:
1.
2.
3.

Actual results:

Scaled up gears are missing built artifacts in ~/jbossews.


Expected results:

Scaled up gears should be in sync with the head gear's build output.

Additional info:
Comment 2 openshift-github-bot 2013-07-10 15:58:48 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/0becce09fd0ab8db5c7e2964c854f916682c32eb
Bug 983216: Use rsync for jbossews deployments rather than mv
Comment 3 Meng Bo 2013-07-11 04:39:05 EDT
Checked on devenv_3482 with 3-gear scalable jbossews2.0 app.

Placed a pre-built sample.war into the webapps/ and push the change.

Found it using rsync instead of mv in the git push log.
remote: + rsync -r --delete /var/lib/openshift/966457217098891931942912/app-root/runtime/repo//webapps/ /var/lib/openshift/966457217098891931942912/jbossews//webapps/

Check the web gears, the war exist for all gears.
# rhc ssh jbews2s --gear "ls \$OPENSHIFT_JBOSSEWS_DIR/webapps/"
=== 999629402297430465052672 jbossews-2.0+haproxy-1.4
ROOT.war
sample.war
=== 966457217098891931942912 jbossews-2.0+haproxy-1.4
ROOT.war
sample.war
=== dda1e0c8ea0311e29af122000a8a0ade jbossews-2.0+haproxy-1.4
ROOT.war
sample.war
Comment 4 Dan Mace 2013-07-11 14:17:09 EDT
*** Bug 983494 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.