Bug 98323 - XFree86 crashed Intel i815
XFree86 crashed Intel i815
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-30 22:58 EDT by Raanan
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version: 4.2.1-21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-03 18:04:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages & XFree86.0.log (33.68 KB, application/x-zip-compressed)
2003-06-30 23:01 EDT, Raanan
no flags Details
XFree86.0.log (124.25 KB, text/plain)
2003-07-04 01:38 EDT, Raanan
no flags Details
messages File (301.41 KB, text/plain)
2003-07-04 01:40 EDT, Raanan
no flags Details

  None (edit)
Description Raanan 2003-06-30 22:58:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Hi,
I'm using Redhat 8.
My problem has started (I don't know if it's related) after the system tried to 
bootup while the "/" filesystem (my only file system beside /boot and swap) was 
100% full.
I'm running init 5 and when the system reached to the end of the boot proccess 
(when it supposed to switch to X) it crashes with the following message:

[drm:i810_wait_ring]*ERROR* space: 65520 wanted 65528
[drm:i810_wait_ring]*ERROR* lockup

now, every 2-3 seconds the system tried to go into X and gave these errors 
again.
I'm using Compaq deskpro EN 866Mhz with Intel i815 graphic display adapter (on 
board),
My system worked fine since I installed it last week and suddenly this happend.

I'm attaching the /var/log/messages and the /var/log/XFree86.0.log

Thanks,
Raanan.

Version-Release number of selected component (if applicable):
4.2

How reproducible:
Always

Steps to Reproduce:
Every init 5

Additional info:
Comment 1 Raanan 2003-06-30 23:01:16 EDT
Created attachment 92701 [details]
messages & XFree86.0.log
Comment 2 Mike A. Harris 2003-06-30 23:19:45 EDT
Those are kernel error messages from the DRM.  This is likely an i810 kernel
DRM problem.

As far as your disk space problem goes, you must ensure that free disk space
is always available for applications, in particular in the /tmp partition.
If your disk gets 100% full, many applications will definitely fail, and that
is because they require free disk space to operate correctly.  In such a
case, free up as much space as possible, and then reboot your system.  You
may also need to remove dead lock files and temporary files after such a
problem occurs in some cases.

Once you free up disk space and reboot, does the problem still occur?  I'm
assuming they are 2 different problems.

On a side note, please attach files as individual uncompressed file attachments
so they can be viewed by developers directly in the web browser by clicking on
them.

Thanks in advance.
Comment 3 Raanan 2003-07-01 08:56:31 EDT
Sorry for not mention that...
Yes, the first thing I did when I found out that my disk is full is to free 
1.5GB, but the problem still occur.

Also do you still need me to attache the files as plain text ?


Thanks,
Raanan.
Comment 4 Raanan 2003-07-03 12:39:22 EDT
I remarked the FontPath "unix/:7100" line on the /etc/X11/XF86Config file and 
it solved my problem.

Can you please tell me what this line doing, why I have this problem and what 
to do in order to remove the remark ?

Thanks,
Raanan.
Comment 5 Mike A. Harris 2003-07-03 15:29:18 EDT
Awaiting log and config file in browser clickable attachments.
Comment 6 Raanan 2003-07-04 01:38:06 EDT
Created attachment 92755 [details]
XFree86.0.log
Comment 7 Raanan 2003-07-04 01:40:37 EDT
Created attachment 92756 [details]
messages File
Comment 8 Mike A. Harris 2003-08-03 18:04:34 EDT
Ok, the log file shows that you are not running the latest XFree86 update.  It
is most likely that the 4.2.1-20 you're running resulted in filling up your disk
space upon upgrade, as that release accidentally contained full debugging
information due to a glitch in our buildsystem.  You should upgrade ASAP to
4.2.1-21 which was released a few days later, which resolved that issue.

What I believe has happened, is you've upgraded to the 4.2.1-20 release with
low disk space, and that release required 3-4 times the free disk space available
plus the size of the existing X installation due to the problem mentioned
above.  That caused your disk to be full, and xfs was unable to create it's
socket in /tmp on startup, resulting in no font server running which
prevents X from starting up.

You will need to free up a few hundred megabytes of disk space somehow,
and then upgrade to all latest updates available via up2date, restart your
system and the problem hopefully go away.

Closing as fixed in 4.2.1-21 ERRATA

Note You need to log in before you can comment on or make changes to this bug.