Bug 983231 - [abrt] system-config-services-0.101.10-1.fc19: connection.py:651:call_blocking:DBusException: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
[abrt] system-config-services-0.101.10-1.fc19: connection.py:651:call_blockin...
Status: CLOSED DUPLICATE of bug 1046720
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
abrt_hash:dbac5f43345a9d129e21b3e54e1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 14:59 EDT by dscribner
Modified: 2014-03-20 07:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-20 07:30:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.36 KB, text/plain)
2013-07-10 14:59 EDT, dscribner
no flags Details
File: core_backtrace (1.25 KB, text/plain)
2013-07-10 14:59 EDT, dscribner
no flags Details
File: dso_list (68 bytes, text/plain)
2013-07-10 14:59 EDT, dscribner
no flags Details
File: environ (1.80 KB, text/plain)
2013-07-10 14:59 EDT, dscribner
no flags Details

  None (edit)
Description dscribner 2013-07-10 14:59:04 EDT
Version-Release number of selected component:
system-config-services-0.101.10-1.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/bin/system-config-services
executable:     /usr/bin/system-config-services
kernel:         3.9.9-301.fc19.x86_64
runlevel:       N 5
uid:            500

Truncated backtrace:
connection.py:651:call_blocking:DBusException: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/scservices/gui/__init__.py", line 634, in on_systemd_unit_new
    self._on_unit_properties_changed(unit)
  File "/usr/lib/python2.7/site-packages/scservices/gui/__init__.py", line 876, in _on_unit_properties_changed
    self.on_service_conf_changed(unit)
  File "/usr/lib/python2.7/site-packages/scservices/gui/__init__.py", line 889, in on_service_conf_changed
    self._set_widgets_sensitivity()
  File "/usr/lib/python2.7/site-packages/scservices/gui/__init__.py", line 687, in _set_widgets_sensitivity
    self._set_service_widget_sensitive(widget, self.current_service)
  File "/usr/lib/python2.7/site-packages/scservices/gui/__init__.py", line 708, in _set_service_widget_sensitive
    is_enabled = service.get_enabled()
  File "<string>", line 2, in get_enabled
  File "/usr/lib/python2.7/site-packages/slip/dbus/polkit.py", line 103, in _enable_proxy
    return func(*p, **k)
  File "/usr/lib/python2.7/site-packages/scservices/dbus/proxy/services.py", line 85, in get_enabled
    return self.chkconfig_interface.get_enabled()
  File "/usr/lib/python2.7/site-packages/slip/dbus/proxies.py", line 50, in __call__
    return dbus.proxies._ProxyMethod.__call__(self, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SystemBus (system) at 0x7ff928931dd0>
args: ()
object_path: u'/org/fedoraproject/Config/Services/ServiceHerders/XinetdServiceHerder/Services/chargen_dgram'
signature: ''
bus_name: dbus.UTF8String(':1.85')
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
timeout: 2147483.647
kwargs: {}
dbus_interface: 'org.fedoraproject.Config.Services.ChkconfigService'
message: <dbus.lowlevel.MethodCallMessage path: /org/fedoraproject/Config/Services/ServiceHerders/XinetdServiceHerder/Services/chargen_dgram, iface: org.fedoraproject.Config.Services.ChkconfigService, member: get_enabled dest: :1.85>
method: 'get_enabled'

Potential duplicate: bug 870728
Comment 1 dscribner 2013-07-10 14:59:08 EDT
Created attachment 771782 [details]
File: backtrace
Comment 2 dscribner 2013-07-10 14:59:10 EDT
Created attachment 771783 [details]
File: core_backtrace
Comment 3 dscribner 2013-07-10 14:59:12 EDT
Created attachment 771784 [details]
File: dso_list
Comment 4 dscribner 2013-07-10 14:59:15 EDT
Created attachment 771785 [details]
File: environ
Comment 5 Jaromír Končický 2014-03-20 07:30:59 EDT

*** This bug has been marked as a duplicate of bug 1046720 ***

Note You need to log in before you can comment on or make changes to this bug.