Bug 983324 - Seeing ConcurrentModificationException in EJBClientContext on start up.
Seeing ConcurrentModificationException in EJBClientContext on start up.
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity medium
: ER7
: EAP 6.1.1
Assigned To: Jaikiran Pai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-10 20:53 EDT by dstephan
Modified: 2013-10-23 19:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This bugzilla addresses an issue in the EJB client library, where registering an EJBReceiver to a EJBClientContext could sometimes fail with java.util.ConcurrentModificationException because of an incorrect handling of a datastructure while dealing with multiple threads. After this fix in the EJB client library, users won't be seeing this exception while registering EJBReceiver(s) to an EJBClientContext.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:24:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dstephan 2013-07-10 20:53:57 EDT
Description of problem:

Seeing this Stacktrace:

Caused by: java.util.ConcurrentModificationException
        at java.util.HashMap$HashIterator.nextEntry(HashMap.java:894) [rt.jar:1.7.0_21]
        at java.util.HashMap$KeyIterator.next(HashMap.java:928) [rt.jar:1.7.0_21]
        at org.jboss.ejb.client.EJBClientContext.registerEJBReceiver(EJBClientContext.java:390)
        at org.jboss.ejb.client.EJBClientContext.registerEJBReceiver(EJBClientContext.java:327)

this looks to be fixed in 2.0.0.Beta here:

https://github.com/jbossas/jboss-ejb-client/commit/8a34304c78f7008a79a743f4f750ffec1c48ab91

Can this be included in EAP 6.1.x ?
Comment 1 Jaikiran Pai 2013-07-10 22:54:51 EDT
It's already fixed in the version that's integrated for 6.1.1.
Comment 2 Jan Martiska 2013-08-29 05:16:55 EDT
Fixed in EJB client 1.0.22.Final, EAP 6.1.1.ER7 contains 1.0.23.Final. Closing.

Note You need to log in before you can comment on or make changes to this bug.