Bug 983363 - pkg_resources.DistributionNotFound: requests>=1.2.3
pkg_resources.DistributionNotFound: requests>=1.2.3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: httpie (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ricky Elrod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 01:26 EDT by Luke Macken
Modified: 2016-09-19 22:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: httpie-0.6.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-21 20:37:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2013-07-11 01:26:34 EDT
Description of problem:
▶ http
Traceback (most recent call last):
  File "/usr/bin/http", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2809, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 594, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: requests>=1.2.3


Version-Release number of selected component (if applicable):
httpie-0.6.0-2.fc19.noarch
Comment 1 Christopher Meng 2013-07-11 01:54:50 EDT
This is because package "python-requests" is not up-to-date.

I've done a search for f19 and found that the version of "python-requests" is 1.1.

Please also file a bug of requesting a new version under component "python-requests".
Comment 2 Fedora Update System 2013-07-11 02:41:56 EDT
httpie-0.6.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/httpie-0.6.0-3.fc19
Comment 3 Luke Macken 2013-07-11 14:27:27 EDT
I just added requests to the Upstream Monitoring service, so hopefully a bug will get created automatically during the next run. https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 4 Fedora Update System 2013-07-11 23:16:05 EDT
Package httpie-0.6.0-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing httpie-0.6.0-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12846/httpie-0.6.0-3.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-07-21 20:37:11 EDT
httpie-0.6.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.