Bug 983372 - Sorting of task list based on Id/Name/Priority/Status/DueOn columns not working
Sorting of task list based on Id/Name/Priority/Status/DueOn columns not working
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER2
: 6.0.0
Assigned To: Mauricio Salatino
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 01:50 EDT by Jan Hrcek
Modified: 2014-08-06 16:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:13:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hrcek 2013-07-11 01:50:42 EDT
Description of problem:
Sorting of task lisk based on Id/Name/Priority/Status/DueOn by clicking at column headers no longer works (it worked previously in DR5)

Version-Release number of selected component (if applicable):
6.0.0.Beta 5

How reproducible:
Always in my environment with Firefox 22 / Fedora 19

Steps to Reproduce:
1. Go to Tasks > Tasks List
2. Add several task using New Task (different priorities/names)
3. Click column headers (Id, Task etc...)

Actual results:
The list is not sorted

Expected results:
Sorting of list based on value in column, on whose header user clicked.
Repetitive clicking should switch between ascending/descending sort order.

Additional info:
Ability to organize the tasks by various criteria is one of the PRD requirements (PET-9)

There seems to be the same issue in "Process Definitions" and "Process Instances" tabs. On the contrary, if you check "Process Instance Details", there is a table of process variables, in which the sorting works as it should.
Comment 1 Mauricio Salatino 2013-07-15 06:11:58 EDT
Fixed in master:
http://github.com/droolsjbpm/jbpm-console-ng/commit/4edd06d0c
Comment 2 Mauricio Salatino 2013-07-15 06:12:10 EDT
Fixed in master:
http://github.com/droolsjbpm/jbpm-console-ng/commit/4edd06d0c
Comment 3 Jan Hrcek 2013-09-04 03:02:51 EDT
Verified with BPMS 6.0.0.ER2

Note You need to log in before you can comment on or make changes to this bug.