Bug 983399 - Rebalance : Few files missing on mount point after rebalance process
Rebalance : Few files missing on mount point after rebalance process
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Nagaprasad Sathyanarayana
:
Depends On: 976755
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 02:58 EDT by shishir gowda
Modified: 2016-02-17 19:19 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 976755
Environment:
Last Closed: 2014-04-17 07:43:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-07-11 02:59:47 EDT
REVIEW: http://review.gluster.org/5316 (cluster/dht: Unlink dst file after cleanup during migration) posted (#1) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 2 Anand Avati 2013-07-12 03:41:07 EDT
COMMIT: http://review.gluster.org/5316 committed in master by Anand Avati (avati@redhat.com) 
------
commit ec64f13476cbd2f7702cecfef929f3ea8efc0a51
Author: shishir gowda <sgowda@redhat.com>
Date:   Thu Jul 11 11:52:25 2013 +0530

    cluster/dht: Unlink dst file after cleanup during migration
    
    If a rename happens during migration, unlink fails. This leads
    to stale xattrs, and Sticky bits still being set.
    
    By removing the xattrs and Sticky bits from dst (through fd ops),
    the stale link file would be cleaned up eventually (even if unlink
    fails on src).
    
    Change-Id: Iec537d021905438327a20e1d811aa06e74034364
    BUG: 983399
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/5316
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 5 Niels de Vos 2014-04-17 07:43:24 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.