Bug 98340 - mkinitrd ignores options param from /etc/modules.conf
Summary: mkinitrd ignores options param from /etc/modules.conf
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-01 14:01 UTC by Bill Peck
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version: 3.4.47
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-01 14:16:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Peck 2003-07-01 14:01:41 UTC
Description of problem:
Setting options scsi_mod max_scsi_luns=128 and running mkinitrd should create
a ramdisk image with insmod scsi_mod max_scsi_luns=128 but it doesn't.

Looking a little closer at the mkinitrd script it seems that the following line
has changed in Shrike:

module=`echo $MODULE | sed "s|.*/||"`

in Enigma 7.2 the line is :

module=`echo $MODULE | sed "s|.*/||" | sed "s/.o$//"`

Which works.  I checked documentation for mkinitrd but I can't find any mention
of a change in how this should work. 

Version-Release number of selected component (if applicable):
mkinitrd-3.4.42-1

How reproducible:
Everytime

Steps to Reproduce:
1. add options scsi_mod max_scsi_luns=128 to /etc/modules.conf
2. mkinitrd -f /boot/initrd.img 2.4.20-8
3. reboot or check the initrd.img file..  you will see no mention of max_scsi_luns
    
Actual results:
no options will be picked up by mkinitrd

Expected results:
options will be picked up

Additional info:

Comment 1 Jeremy Katz 2003-07-01 14:16:26 UTC
Fixed since 3.4.47


Note You need to log in before you can comment on or make changes to this bug.