Bug 98348 - mod_auth_any has lots of zombies
mod_auth_any has lots of zombies
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: mod_auth_any (Show other bugs)
2.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-01 11:16 EDT by David L. Parsley
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:24:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David L. Parsley 2003-07-01 11:16:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
I use a script called 'winauth.sh' to authenticate to an NT domain with wbinfo
and winbindd.  However, every call to winauth.sh leaves a winauth.sh zombie! 
The parent is one of apache's httpd processes.  I removed mod_auth_any and
compiled from source, and that doesn't leave any zombies.  The apache version is
apache-1.3.27-2.

I'd bet that _any_ script used with mod_auth_any will trigger this bug, but
here's mine:
<script>
#!/bin/bash

# Prog to authenticate using Samba winbindd, for use with mod_auth_any

USER=$1
shift
# for passwords with spaces...
PASS="$*"

/usr/bin/wbinfo -a "${USER}%${PASS}" > /dev/null
RETVAL=$?

if [ $RETVAL -eq 0 ]
then
        echo $USER
fi
exit $RETVAL
</script>

Version-Release number of selected component (if applicable):
mod_auth_any-1.2.2-2

How reproducible:
Always

Additional info:

Note that I've set severity to high, since running the stock mod_auth_any will
hose the box up good with gobs of zombies (which is what initially happened to
me).  My box is working fine for now, but a real fix from redhat would be
appreciated.
Comment 1 RHEL Product and Program Management 2007-10-19 15:24:45 EDT
This bug is filed against RHEL2.1, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products.  Since
this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/

If you feel this bug is indeed mission critical, please contact your
support representative.  You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.