Bug 983509 - WorkDefinitions.wid file generated for a newly created process not visible right away.
WorkDefinitions.wid file generated for a newly created process not visible ri...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium
: ER4
: 6.0.0
Assigned To: Tihomir Surdilovic
Tomas Livora
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 06:54 EDT by Marek Baluch
Modified: 2014-08-06 16:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:13:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Baluch 2013-07-11 06:54:52 EDT
Description of problem:
When a new BPMN 2 process is created in a new project then a WorkDefinition.wid file is generated. This file contains the Email and Log work item definitions. The process will be visible in the directory in Guvnor right away but the WorkDefinitions.wid file will not. A refresh is required.


How to reproduce:
1) create a new project
2) create a new package in the src/resources directory
3) create a new BPMN2 process.


Expected result:
Both process file and wid file visible.

Actual result:
Only process file is visible.

Affected version:
DR6
Comment 2 Mauricio Salatino 2013-07-11 18:18:03 EDT
I'm assigning this issue to Michael Anstis, because this is about building the kjar which is out side of the BPM side. I know that the WorkDefinitions.wid file is related with the processes, but the policies to include or exclude files are in a core module.
Comment 3 manstis 2013-09-06 11:13:44 EDT
There is a very similar (if not identical) BZ to this already that was assigned to tsurdilo (WIDs created along with a process are not in the KJAR). I have verified creating a new WID directly (i.e. New->Work Item Definition) works OK. The same root cause is at play - probably a NewResourceEvent is not being raised for the WID.
Comment 4 Kris Verlaenen 2013-09-16 09:57:21 EDT
This also seems to be causing another side effect: when opening designer for the first time, since the generated .wid is not immediately picked up, the service tasks category remains empty (no way to add one of the custom service tasks).  Reopening designer a second time makes the category show up correctly.
Comment 5 Tihomir Surdilovic 2013-09-18 08:51:12 EDT
Fixed in master and 6.0.x branches of designer. Designer is now able to find the installed workitem definitions config in a new repo+project right away and re-open is no longer necessary.
Comment 7 Tomas Livora 2013-10-16 04:33:25 EDT
Verified on BPMS 6.0.0.ER4

Note You need to log in before you can comment on or make changes to this bug.