Bug 983547 - Auto-install fails
Auto-install fails
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Deutsch
:
Depends On:
Blocks: ovirt-node-3.0
  Show dependency treegraph
 
Reported: 2013-07-11 08:38 EDT by Fabian Deutsch
Modified: 2016-04-26 13:05 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovrt-node-3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 05:48:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16855 None None None Never

  None (edit)
Description Fabian Deutsch 2013-07-11 08:38:35 EDT
Description of problem:

Auto-install fails on 3.0 RC
Comment 1 Fabian Deutsch 2013-07-15 08:55:44 EDT
After many hours of investigation it seems that the problem were insufficient service dependencies.
Due To the incorrect dependencies it could happen that multiple ovirt related jobs ran concurrently with ovirt-firstboot. The current assumption is, that one of these services restarted a service (e.g. network.service/.target) or messed with a unit (e.g. a mount) which was an (in-)direct dependency of ovirt-firstboot.

The patch below adjusts the dependencies to prevent concurret runs of different ovirt node services with ovirt-firstboot and drops the dependency (Want=) of ovirt-firstboot on th network.service (because firstboot restarts networking, which brings down the unit).

http://gerrit.ovirt.org/16855

How to test:
1. Boot with BOOTIF=link storage_init
2. Await successful installation.

Mainly ensure that the system is rebooting and not dropping to a login prompt.
Comment 2 Fabian Deutsch 2013-08-26 05:45:33 EDT
The fix for this patch has been merged and is present in the released ovirt-node-3.0.0.

Note You need to log in before you can comment on or make changes to this bug.