This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 983556 - "Package consistently uses macro is (..)."
"Package consistently uses macro is (..)."
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-review (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 09:17 EDT by Jens Petersen
Modified: 2013-08-30 09:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 09:28:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2013-07-11 09:17:58 EDT
Description of problem:
plugins/generic.py seems to generate the text
"Package consistently uses macro is (..)."
                           ^^^^^^^^
in review.txt, which does not make sense!

I suppose it should just say "Package consistently uses *macros* (..)."

Version-Release number of selected component (if applicable):
fedora-review-0.4.1-2.fc19

How reproducible:
100%

Additional info:
I see the same in the master and devel branches in git.
Comment 1 Alec Leamas 2013-07-29 04:18:32 EDT
Hm... this should be fixed in 3daa8d6683, dated Jan 28, 2013. I certainly see it in older branches, but not in current devel. 

Could you please provide a more specific test case, including a bug and last commit in devel?
Comment 2 Jens Petersen 2013-07-29 22:13:26 EDT
Sure:

$ rpm -q fedora-review
fedora-review-0.4.1-2.fc19.noarch
$ rpm -ql fedora-review | LANG=C xargs grep -d skip "uses macro is"
Binary file /usr/share/fedora-review/plugins/generic.pyc matches
Binary file /usr/share/fedora-review/plugins/generic.pyo matches
$ rpm -V fedora-review
$ 

Perhaps the python files were not recompiled properly?
Comment 3 Jens Petersen 2013-07-29 23:54:36 EDT
Same for rawhide
Comment 4 Jens Petersen 2013-07-30 00:04:46 EDT
You're right it is fixed in upstream devel branch
but still present in the master branch.
Comment 5 Alec Leamas 2013-07-30 01:17:04 EDT
As explained in the wiki, the master branch is not really useful in the model we use - it's basically just the release branches collected over time. The important thing is that this is fixed in devel, the upcoming release.

Since we agree on this I close this. Thanks for reporting the issue (and for all checking!)
Comment 6 Jens Petersen 2013-08-05 08:40:54 EDT
Can we keep this open until it is available in current releases?

When do you plan to update the f19 package say?
Comment 7 Alec Leamas 2013-08-30 09:28:45 EDT
Fixed in 0.5.0 release.

Note You need to log in before you can comment on or make changes to this bug.