This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 983605 - Remove Online-specific text from gear shell message
Remove Online-specific text from gear shell message
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Michal Fojtik
libra bugs
:
Depends On:
Blocks: 974692
  Show dependency treegraph
 
Reported: 2013-07-11 10:33 EDT by Brenton Leanhardt
Modified: 2015-05-14 19:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 974692
Environment:
Last Closed: 2013-08-29 08:46:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brenton Leanhardt 2013-07-11 10:33:07 EDT
We won't want Origin to reference the Online legal terms.

+++ This bug was initially created as a clone of Bug #974692 +++

Description of problem:
When a developer logs into their gear, they are greeted by a message. This message has some Online-specific components that should be removed. Ideally, it would actually be completely configurable by the administrator.

Actual results:
    *********************************************************************

    You are accessing a service that is for use only by authorized users.  
    If you do not have authorization, discontinue use at once. 
    Any use of the services is subject to the applicable terms of the 
    agreement which can be found at: 
    https://www.openshift.com/legal

    *********************************************************************


Expected results:
Nothing about www.openshift.com/legal. In fact, I'd like an option in /etc/openshift/node.conf to specify a file to use instead of this message.

Additional info:
Probably be best to get rid of the v2 cart msg too.

--- Additional comment from RHEL Product and Program Management on 2013-06-14 16:26:07 EDT ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Brenton Leanhardt on 2013-07-11 10:31:19 EDT ---

Let's skin this appropriately.  I'm going to clone this to Origin.
Comment 1 Michal Fojtik 2013-08-20 11:03:16 EDT
Hi guys,

I made a pull request to fix this issue:
https://github.com/openshift/origin-server/pull/3432
Comment 2 openshift-github-bot 2013-08-22 18:08:03 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/3976aab0642909ff4fe16cd3ef82fc87f9cd6763
Bug 983605 - Allow to administrator to change the default 'rhc ssh' motd
Comment 4 Meng Bo 2013-08-25 23:15:48 EDT
Checked on devenv_3706,

1.Add following line into node.conf file
MOTD_FILE="/etc/openshift/welcome.rhcsh"
2.Create file with test strings
# cat /etc/openshift/welcome.rhcsh
test
3.Restart mcollective service
4.SSH login to gears

# ssh cc9909340dfb11e3bc7a22000ab3288a@app2-bmeng.dev.rhcloud.com
test
[app2-bmeng.dev.rhcloud.com cc9909340dfb11e3bc7a22000ab3288a]\> 

Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.