Bug 983622 - no hardening build
no hardening build
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: udisks2 (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 10:45 EDT by Harald Reindl
Modified: 2015-03-03 18:06 EST (History)
2 users (show)

See Also:
Fixed In Version: udisks2-2.0.1-3.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-03 20:06:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2013-07-11 10:45:26 EDT
checksec:
udisksd  14589 Partial RELRO     Canary found           NX enabled    No PIE

* no "FULL RELRO"
* no PIE

udisksd is a long living process running even as root
_________________________________________________

If your package meets any of the following criteria you MUST enable the PIE compiler flags:

    Your package is long running. This means it's likely to be started and keep running until the machine is rebooted, not start on demand and quit on idle. 

    Your package has suid binaries, or binaries with capabilities. 

    Your package runs as root. 

If your package meets the following criteria you should consider enabling the PIE compiler flags:

    Your package accepts/processes untrusted input.
Comment 1 Fedora Update System 2013-07-25 10:32:16 EDT
udisks2-2.0.1-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/udisks2-2.0.1-3.fc18
Comment 2 Tomáš Bžatek 2013-07-25 10:34:50 EDT
I've used the %global _hardened_build macro, hope it's sufficient for a hardened build. In F19 and rawhide packages a different approach has been used due to previous issues with the macro.
Comment 3 Fedora Update System 2013-07-25 20:25:55 EDT
Package udisks2-2.0.1-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing udisks2-2.0.1-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13612/udisks2-2.0.1-3.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-08-03 20:06:44 EDT
udisks2-2.0.1-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.