Bug 983632 - NetworkManager-vpnc-gnome is not installed on update
NetworkManager-vpnc-gnome is not installed on update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 11:13 EDT by Maros Zatko
Modified: 2013-08-01 23:31 EDT (History)
3 users (show)

See Also:
Fixed In Version: NetworkManager-vpnc-0.9.8.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 23:31:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maros Zatko 2013-07-11 11:13:04 EDT
Description of problem:
I was trying to connect to VPN but it was failing repeatedly.
So I killed my session using C-M-Del to log out and in again
and then my VPN item was no longer in nm-applets VPN menu.

Version-Release number of selected component (if applicable):
0.9.8.2-1.fc19

How reproducible:
?

Steps to Reproduce:
In description.

Actual results:
VPN config gone.

Expected results:
Connected to VPN as usual.
Comment 1 Jirka Klimes 2013-07-25 03:09:18 EDT
What type of VPN do you use (vpnc, openvpn, ...)? What's the version of NetworkManager-vpnc, NetworkManager-openvpn ?
Please check that you have installed NetworkManager-vpnc-gnome.
Comment 2 Maros Zatko 2013-07-25 05:49:22 EDT
The bug is more intrigue because after I killed the xorg session again, the VPN connection was back in NM menu.

NetworkManager-vpnc 0.9.3.997-4.fc19, repo:installed
NetworkManager-openvpn 0.9.8.2-2.fc19 repo:updates/19/x86_64
$ yum info NetworkManager-vpnc-gnome
Loaded plugins: langpacks, refresh-packagekit
Error: No matching Packages to list

From installed packages I suppose I'm using vpnc.

I don't know if version is relevant any more, since I've updated
several times since the incident.

N.b.: Gnome desktop is not installed.
Comment 3 Dan Williams 2013-07-25 17:12:05 EDT
I'm pretty sure this is the VPN plugin split Epoch issue.  I made the original mistake in the vpnc plugin that I think got copied to the other plugins too.

-Obsoletes: NetworkManager-vpnc < 0.9.8.2-1
+Obsoletes: NetworkManager-vpnc < 1:0.9.8.2-1
Comment 4 Fedora Update System 2013-07-26 04:44:27 EDT
NetworkManager-vpnc-0.9.8.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/NetworkManager-vpnc-0.9.8.2-2.fc19
Comment 5 Fedora Update System 2013-07-26 19:03:25 EDT
Package NetworkManager-vpnc-0.9.8.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-vpnc-0.9.8.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13705/NetworkManager-vpnc-0.9.8.2-2.fc19
then log in and leave karma (feedback).
Comment 6 Maros Zatko 2013-07-29 08:29:28 EDT
So I've run yum update --enablerepo=updates-testing NetworkManager-vpnc-0.9.8.2-2.fc19 as root.

NetworkManager-vpnc-gnome is thankfully still not installed.

Btw, how does this gnome thingy actually relates to my 'issue', pretty please?
Comment 7 Jirka Klimes 2013-07-30 10:53:45 EDT
(In reply to Maros Zatko from comment #6)
> So I've run yum update --enablerepo=updates-testing
> NetworkManager-vpnc-0.9.8.2-2.fc19 as root.
> 
> NetworkManager-vpnc-gnome is thankfully still not installed.
> 
> Btw, how does this gnome thingy actually relates to my 'issue', pretty
> please?

NetworkManager-vpnc-gnome package contains dialog and properties for nm-connection-editor, so that you can add and edit vpnc connections. So you need it even if you don't use Gnome. Don't be afraid of the package, it won't pull any dependencies.

You should run:
yum update --enablerepo=updates-testing NetworkManager-vpnc

which will properly install NetworkManager-vpnc and NetworkManager-vpnc-gnome
Comment 8 Maros Zatko 2013-07-31 06:45:49 EDT
I did run it successfully before (two days ago).
Again, it did *not* install NetworkManager-vpnc-gnome.

What did I do wrong?

Installed Packages
Name        : NetworkManager-vpnc
Version     : 0.9.8.2
Release     : 2.fc19

Available Packages
Name        : NetworkManager-vpnc-gnome
Version     : 0.9.8.2
Release     : 1.fc19
Comment 9 Fedora Update System 2013-08-01 23:31:31 EDT
NetworkManager-vpnc-0.9.8.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.