Bug 983644 - Adding Graph to Monitoring->Metrics Fails
Adding Graph to Monitoring->Metrics Fails
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.1.2
All Linux
unspecified Severity high
: ER07
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 1035501
  Show dependency treegraph
 
Reported: 2013-07-11 11:27 EDT by Will Dinyes
Modified: 2014-01-02 15:34 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:34:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Dinyes 2013-07-11 11:27:22 EDT
Description of problem:

When attempting to add a graph of the metric "Total Number of Commands Received" for my RHQ Agent, the graph fails to show up, even though the metric is being collected.

Version-Release number of selected component (if applicable):

3.1.2.GA

How reproducible:

Very.

Steps to Reproduce:
1. Log in to JBoss Operations Network
2. Ensure you have added an RHQ Agent to your monitored resources.
3. Navigate to Inventory > Servers and click RHQ Agent
4. On the RHQ Agent page, navgate to Monitoring > Schedules
5. Enable Total Number of Commands Received and set collection interval to 1 minute.
6. Navigate to Monitoring > Graphs
7. In the left column of the UI, right-click RHQ Agent, and select Measurements > Total Number of Commands Received > Add Graph to Monitor View

Actual results:

No graph is added to the display.

Expected results:

Graph of Total Number of Commands Received should appear at the bottom of the displayed graphs.

Additional info:
Comment 1 Heiko W. Rupp 2013-08-28 07:22:25 EDT
Adding the graph to the charts works in 3.2 alpha (= current master)

But each time I add a chart like this I see this error in the console log:

12:24:49,860 ERROR [org.apache.struts.action.RequestProcessor] (http-/0.0.0.0:7080-5) Invalid path was requested /resource/common/monitor/visibility/IndicatorCharts
12:53:50,945 ERROR [org.apache.struts.action.RequestProcessor] (http-/0.0.0.0:7080-1) Invalid path was requested /resource/common/monitor/visibility/IndicatorCharts

I see two references to that 
org.rhq.enterprise.gui.coregui.client.inventory.resource.detail.DashboardLinkUtility#addNewMetric
and
org.rhq.enterprise.gui.coregui.client.inventory.groups.detail.ResourceGroupContextMenu#buildMetricsMenu

inside coregui.
Comment 2 Lukas Krejci 2013-11-21 13:08:21 EST
This is no longer applicable, because the graphs page has been merged with metrics page and all enabled metrics are always shown on that page.
Comment 3 Armine Hovsepyan 2013-11-25 12:34:26 EST
as mentioned in comment #2, graphs are visible in metrics page (even though "add graph to monitor view" is still visible)
Comment 4 Mike Thompson 2013-11-27 18:33:35 EST
Added BZ 1035501 to handle the removal of 'Add Graph to Monitor View' Menu Item in Resource Tree.

Note You need to log in before you can comment on or make changes to this bug.