Bug 983649 - RFE: create additional scheduler parameters for VM creation and deletion
RFE: create additional scheduler parameters for VM creation and deletion
Status: CLOSED DUPLICATE of bug 978542
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
4.0
All All
medium Severity low
: Upstream M3
: 5.0 (RHEL 7)
Assigned To: Nikola Dipanov
Omri Hochman
https://blueprints.launchpad.net/nova...
upstream_milestone_icehouse-3 upstrea...
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 11:36 EDT by Dan Yocum
Modified: 2016-04-26 18:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-29 21:13:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yocum 2013-07-11 11:36:14 EDT
This is in regards to https://bugzilla.redhat.com/show_bug.cgi?id=957267

There should be a NetworkBandwidthFilter for the scheduler to properly schedule instance creation.  Or maybe a scheduler_attempts_delay parameter that would work in conjunction with the scheduler_max_attempts.  The Condor schedd guys probably would have some insight, here.
Comment 2 Nikola Dipanov 2013-09-25 10:17:32 EDT
There are two blueprints that seem to do what this RFE proposes currently, and they both failed to make Havana.

* Network bandwith entitlement for flavors: https://blueprints.launchpad.net/nova/+spec/network-bandwidth-entitlement

This one seems to have been somewhat abandoned.

* A more structured approach was laid out in https://blueprints.launchpad.net/nova/+spec/utilization-aware-scheduling there seems to be a lot of solid work done - the patches were rejected due to havana feature freeze.

Linking the blueptrint and moving to RHOS 5.0
Comment 3 Stephen Gordon 2014-01-29 21:13:23 EST

*** This bug has been marked as a duplicate of bug 978542 ***

Note You need to log in before you can comment on or make changes to this bug.