Bug 983683 - spacewalk-splice-tool has no dependency on subscription-manager-migration-data
spacewalk-splice-tool has no dependency on subscription-manager-migration-data
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3
Assigned To: Splice Developers
mkovacik
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-07-11 13:35 EDT by Vitaly Kuznetsov
Modified: 2013-10-01 07:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:01:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1390 normal SHIPPED_LIVE Release 1.3 of Subscription Asset Manager 2013-10-01 10:43:14 EDT

  None (edit)
Description Vitaly Kuznetsov 2013-07-11 13:35:58 EDT
Description of problem:
New subscription-manager-1.8.11-1.el6 has no mappings file (/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt) inside, it was separated into subscription-manager-migration-data package. 

SST run ends with trace:
  File
  "/usr/lib/python2.6/site-packages/spacewalk_splice_tool/utils.py",
  line 35, in read_mapping_file
    f = open(mappingfile)
IOError: [Errno 2] No such file or directory: '/usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt

We should introduce satellite-splice-tool->subscription-manager-migration-data dependency into package.

Version-Release number of selected component (if applicable):
spacewalk-splice-tool-0.27-1
Comment 1 John Matthews 2013-07-16 14:52:41 EDT
https://github.com/splice/spacewalk-splice-tool/commit/fe4d17d82eda26a4dbab90f635c2bd37f3cfe08a

+Requires: subscription-manager-migration-data >= 2.0.1
Comment 2 Bryan Kearney 2013-08-02 14:52:19 EDT
SNAP0 contains these bug fixes. Moving to ON_QA.
Comment 4 Vitaly Kuznetsov 2013-08-21 10:42:30 EDT
Verifies with spacewalk-splice-tool-0.39-1.el6sam.noarch:

# rpm -q --requires spacewalk-splice-tool | grep subscription-manager-migration-data
subscription-manager-migration-data >= 2.0.1
Comment 6 errata-xmlrpc 2013-10-01 07:01:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.