Bug 98373 - makewhatis is just plain broken
Summary: makewhatis is just plain broken
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man   
(Show other bugs)
Version: 9
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-01 19:54 UTC by Steve Coile
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-08 16:41:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Coile 2003-07-01 19:54:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Broken since at least RHL 7.1.

makewhatis doesn't handle man directories outside its fixed path.  Attempting to
add a new man directory to the whatis database clobbers the existing database
completely.

Version-Release number of selected component (if applicable):
man-1.5k-6

How reproducible:
Always

Steps to Reproduce:
1. man -k ls; man -k tripwire
2. makewhatis /usr/local/tripwire/tfs/man
3. man -k ls; man -k tripwire
    

Actual Results:  Existing whatis database gets overwritten.

Expected Results:  Existing database is augmented.

Additional info:

Comment 1 Eido Inoue 2003-08-08 16:41:40 UTC
not a bug. To update an existing database and not overwrite the previous
version, you need to use the command option "-u".



Note You need to log in before you can comment on or make changes to this bug.