Bug 983732 - Locked activity can be modified.
Locked activity can be modified.
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER6
: 6.0.0
Assigned To: Tihomir Surdilovic
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 16:04 EDT by Marek Baluch
Modified: 2014-08-06 16:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:13:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Baluch 2013-07-11 16:04:38 EDT
Description of problem:

Looks like that current locking mechanism relies on preventing selection of a locked activity instead of disabling panels. Basically when I manage to select an activity which has been locked I can change what ever I like.

Locked Activity Modification 1
1) Select an activity
2) Lock it (properties panel has not changed because the activity remains selected so it is still modify the activity)
3) Attempt to modify something

Locked Activity Modification 2
1) Select an locked and deselected activity using the many selection
   a) click and hold the left mouse button
   b) select only the locked activity
2) Attempt to modify something
Comment 1 Marek Baluch 2013-07-12 10:25:05 EDT
Found in DR6 (Beta5).
Comment 2 Prakash Aradhya 2013-09-16 17:18:04 EDT
Internal Whiteboard: Beta Blocker → Blocker
Not critical for Beta, but need to address for GA
Comment 6 Tihomir Surdilovic 2013-11-25 09:28:53 EST
this has been fixed. please retest.
Comment 7 Marek Baluch 2013-12-20 15:33:37 EST
'Locked Activity Modification 2' steps can still be used to modify a locked activity but as has been explained in another issue the behaviour is as designed so marking this as VERIFIED (on ER6)

Note You need to log in before you can comment on or make changes to this bug.