Bug 983746 - anaconda does not correctly install combination "Infrastructure Server" and "Development Tools"
anaconda does not correctly install combination "Infrastructure Server" and "...
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-07-11 16:47 EDT by Michael Capone
Modified: 2013-07-22 11:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-07-22 11:00:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Capone 2013-07-11 16:47:39 EDT
Description of problem:
Doing a standard DVD install of F19, do an install of "Infrastructure Server", if you select the "Development Tools" software package, anaconda will proceed; however, at the end, you will be offered the "Reboot" button while the "Performing Post-installation setup tasks" message is still visible; the "Complete!" message never appears (although the Reboot button is visible and the "Fedora is now successfully installed..." message appears next to it).  Upon reboot, you will get a kernel panic less than three seconds after startup, too early to access the system and do any troubleshooting.  Also, the "Fedora, with linux-0 rescue" option is not created.

Version-Release number of selected component (if applicable): 
F19 / Schrondinger's Cat

How reproducible: 
Consistent, across any machine that we've tried.

Steps to Reproduce:
1. Boot standard x86_64 DVD install.
2. At the "Installation Summary" screen, choose "Software Selection"
3. Choose "Infrastructure Server" on the left; choose "Development Tools" from add-ons on the right.
4. Continue installation (I did not add additional users).  At the end, the Reboot button is presented, but the "Performing post-installation setup tasks" did not change to "Complete!" as expected.

Actual results:
on boot, "Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)" at the 2.38 second mark, followed by about a 10-line call trace; from there, the machine is locked and a hardware reset is required.

Expected results:
A successful install. :)

Additional info:
You can work around this by simply choosing "Infrastructure Server" with no further options, then, upon reboot, doing a yum groupinstall "Development Tools".

The combination "Infrastructure Server" and "C Development Tools and libraries" works as desired. The combination of "Infrastructure Server", "Development Tools", and "C Development Tools and libraries" fails with the same symptoms as described above.  Finally, the combination "Web Server" and "Development Tools" also fails.  The common point of failure is the "Development Tools" option.
Comment 1 Steve Tyler 2013-07-11 18:34:52 EDT
Thanks for your report.

I couldn't reproduce this in a VM. In both test cases, the install succeeds, the system reboots to a root login, and login succeeds:

Infrastructure Server + Development Tools
  Root password set
  Administrator user created
Web Server + Development Tools
  Root password set

Could you attach the installer log files, if possible?
After a successful install, they should be in /var/log/anaconda/.
Otherwise, they should be in /tmp before rebooting from the installer.

Tested with:
$ qemu-img create f19-test-1.img 12G
$ qemu-kvm -m 4096 -hda f19-test-1.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on
Comment 2 Steve Tyler 2013-07-11 18:37:03 EDT
This may be too obvious to ask, but does your installer DVD pass the media test?
Comment 3 Michael Capone 2013-07-11 20:57:59 EDT

Media test.  

"Oh Please," I think to myself.  "I've NEVER had a media test fail.  In fact, I don't even bother with them anymore, since they always pass.  Well, let's just run the media test so we can rule that out and move on with troubleshooting."

The media test failed at 99.9%.  Guess what happened when I burned another DVD and tried again?

My shame burns in my breast like molten lava.

OK, all dramatics aside... thank you for asking the question that was too obvious to ask.  I wish I hadn't spent two days on this. :)  The new DVD installs just fine.  We can close this bug as "operator stupidity" and my humiliation can serve as a shining example to others who encounter such bugs.  You can bet that my IT procedures now have a new step: "Always media-test a new Fedora DVD."  My apologies for the waste of your time. :)
Comment 4 Steve Tyler 2013-07-11 22:15:28 EDT
Thanks for your followup report. I'm just as surprised as you are.
For the record, how are you burning your DVDs?

You can close the bug yourself by changing the status at the bottom of the bug page to CLOSED. For this bug, I would guess the resolution should be NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.