Bug 983755 - [abrt] yumex-3.0.10-2.fc19: misc.py:1017:write:IOError: [Errno 5] Input/output error
[abrt] yumex-3.0.10-2.fc19: misc.py:1017:write:IOError: [Errno 5] Input/outpu...
Status: CLOSED DUPLICATE of bug 881860
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
abrt_hash:7c89e1a319c9a0852627b98db65...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 17:32 EDT by Wilbert Isaac Cortés González
Modified: 2013-09-12 05:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 08:07:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.06 KB, text/plain)
2013-07-11 17:32 EDT, Wilbert Isaac Cortés González
no flags Details
File: core_backtrace (664 bytes, text/plain)
2013-07-11 17:32 EDT, Wilbert Isaac Cortés González
no flags Details
File: environ (315 bytes, text/plain)
2013-07-11 17:32 EDT, Wilbert Isaac Cortés González
no flags Details

  None (edit)
Description Wilbert Isaac Cortés González 2013-07-11 17:32:31 EDT
Version-Release number of selected component:
yumex-3.0.10-2.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python -E /usr/share/yumex/yum_childtask.py 2 True False /etc/yum.conf
dso_list:       yum-3.4.3-99.fc19.noarch
executable:     /usr/share/yumex/yum_childtask.py
kernel:         3.9.9-301.fc19.i686
runlevel:       N 5
uid:            0

Truncated backtrace:
misc.py:1017:write:IOError: [Errno 5] Input/output error

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/yum/rpmtrans.py", line 458, in callback
    self._instProgress( bytes, total, h )
  File "/usr/lib/python2.7/site-packages/yum/rpmtrans.py", line 541, in _instProgress
    self.complete_actions, self.total_actions)
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 1544, in event
    self.base.error('RPM Callback error : %s - %s ' % (self.action[action], str(package)))
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 438, in error
    self.write(":error\t%s" % msg)
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 355, in write
    sys.stdout.write("%s\n" % msg)
  File "/usr/lib/python2.7/site-packages/yum/misc.py", line 1017, in write
    self.stream.write(s)
IOError: [Errno 5] Input/output error

Local variables in innermost frame:
s: ':error\tRPM Callback error : Instalando - python-webob-1.2.3-4.fc19.noarch \n'
self: <open file '<stdout>', mode 'w' at 0xb7734078>
Comment 1 Wilbert Isaac Cortés González 2013-07-11 17:32:34 EDT
Created attachment 772449 [details]
File: backtrace
Comment 2 Wilbert Isaac Cortés González 2013-07-11 17:32:37 EDT
Created attachment 772450 [details]
File: core_backtrace
Comment 3 Wilbert Isaac Cortés González 2013-07-11 17:32:40 EDT
Created attachment 772451 [details]
File: environ
Comment 4 D. Charles Pyle 2013-07-15 02:22:41 EDT
Description of problem:
Tried to run Yumex to check for updates.  PackageKit had the Yum lock.  Tried to close Yumex before it was going to crash anyway, and it still crashed.

Version-Release number of selected component:
yumex-3.0.10-2.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python -E /usr/share/yumex/yum_childtask.py 2 True False /etc/yum.conf
dso_list:       yum-3.4.3-99.fc19.noarch
executable:     /usr/share/yumex/yum_childtask.py
kernel:         3.9.9-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
misc.py:1017:write:IOError: [Errno 5] Input/output error

Traceback (most recent call last):
  File "/usr/share/yumex/yum_childtask.py", line 66, in <module>
    my = YumServer(debuglevel, plugins, offline, repos, yum_conf)
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 187, in __init__
    self.doLock()
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 271, in doLock
    self.warning(_("Yum is locked : ") + e.msg)
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 449, in warning
    self.write(":warning\t%s" % msg)
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 355, in write
    sys.stdout.write("%s\n" % msg)
  File "/usr/lib/python2.7/site-packages/yum/misc.py", line 1017, in write
    self.stream.write(s)
IOError: [Errno 5] Input/output error

Local variables in innermost frame:
s: ':warning\tYum is locked : Existing lock /var/run/yum.pid: another copy is running as pid 2721.\n'
self: <open file '<stdout>', mode 'w' at 0x7f3acab6f150>
Comment 5 Tim Lauridsen 2013-09-10 08:07:26 EDT

*** This bug has been marked as a duplicate of bug 881860 ***
Comment 6 klaus 2013-09-11 14:38:02 EDT
Tried to install grub2 and related packages, then yumex stalled and had to force quit in order to continue, which caused crash and error report.
Comment 7 klaus 2013-09-11 14:40:36 EDT
Please provide a patch and an updated yumex package source that I can install with yum. Thanks.
Comment 8 Tim Lauridsen 2013-09-12 05:29:18 EDT
The IOEror thing kan not be fixed
yumex 3.0.11 is handling locking much better now, please check it out from updates -testing

Note You need to log in before you can comment on or make changes to this bug.