Bug 983781 - Installing JBoss Datagrid as a service
Installing JBoss Datagrid as a service
Status: VERIFIED
Product: JBoss Data Grid 6
Classification: JBoss
Component: Build (Show other bugs)
6.1.0
Unspecified Linux
low Severity low
: ER6
: 6.2.0
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks: 1017190
  Show dependency treegraph
 
Reported: 2013-07-11 20:29 EDT by Guillaume Radde
Modified: 2013-12-18 09:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ISPN-3327 Major Resolved Server init.d script should be customized for Infinispan 2018-02-21 02:44 EST

  None (edit)
Description Guillaume Radde 2013-07-11 20:29:21 EDT
Description of problem:

JBoss Datagrid version 6.1 contains a bin/init.d folder. The folder contains a script that can be used to install Datagrid as a service on unix systems, but the script seems to be for jboss-as, not jboss-datagrid. Also, I could not find any section on installing jboss datagrid as a service. 

Version-Release number of selected component (if applicable):

6.1

How reproducible:

Look in bin/init.d folder

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Vitalii Chepeliuk 2013-09-19 04:07:09 EDT
So I am not able to start JDG Server as service
[root@vchepQA /]# systemctl start infinispan-server.service 
Job failed. See system journal and 'systemctl status' for details.

[Status of service]
infinispan-server.service - SYSV: Infinispan Server
	  Loaded: loaded (/etc/rc.d/init.d/infinispan-server)
	  Active: failed (Result: resources) since Thu, 19 Sep 2013 09:56:21 +0200; 2min 7s ago
	 Process: 9722 ExecStart=/etc/rc.d/init.d/infinispan-server start (code=exited, status=0/SUCCESS)
	Main PID: 8990
	  CGroup: name=systemd:/system/infinispan-server.service

[Log from /var/log/messages]
Sep 19 09:56:21 vchepQA systemd[1]: PID file /var/run/infinispan-server/infinispan-server-standalone.pid not readable (yet?) after start.

[PID of server]
[root@vchepQA /]# lsof -t -i:8080
9785 <<< SO server is started properly and listening

[But there is NO PID file created!!!]
[root@vchepQA /]# ll /var/run/infinispan-server/
total 0

[Problems in script infinispan-server.sh]
1. start()__line__(101) if JDG started, there is "grep 'Infinispan Server.*started in' $ISPN_SERVER_CONSOLE_LOG > /dev/null"
I think should be "grep JBoss Data Grid.* started"
2. standalone.sh does not contain variables like LAUNCH_ISPN_SERVER_IN_BACKGROUND=1 so there is NO need to do %s/JBOSS_/ISPN_SERVER_/g because it does not help if you EXPORT variables and DO NOT use them inside standalone.sh
Comment 3 Martin Gencur 2013-09-19 04:59:34 EDT
The grep command could be universal. Something like grep '.*started.*in.*ms' . I tried this and it worked well for all JDG, ISPN server and EAP, started with or without errors. Just a tip...
Comment 4 JBoss JIRA Server 2013-12-10 06:21:52 EST
Martin Gencur <mgencur@redhat.com> updated the status of jira ISPN-3327 to Reopened
Comment 5 JBoss JIRA Server 2013-12-10 06:21:52 EST
Martin Gencur <mgencur@redhat.com> made a comment on jira ISPN-3327

Looks like this issue should be reopened.

Note You need to log in before you can comment on or make changes to this bug.