Bug 983809 - libreoffice-base misses deps on needed java packages
libreoffice-base misses deps on needed java packages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 22:30 EDT by ItSANgo
Modified: 2013-10-08 07:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 07:45:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample Newdb.odb and strace log (14.72 KB, application/gzip)
2013-07-11 22:30 EDT, ItSANgo
no flags Details

  None (edit)
Description ItSANgo 2013-07-11 22:30:50 EDT
Created attachment 772511 [details]
sample Newdb.odb and strace log

Description of problem:

I am testing Fedora19 x64 in VirtualBox 4.2.16 r86992 on Windows 7 SP1 64 bit .
Host information: https://dl.dropboxusercontent.com/u/86335040/DxDiag17.txt .

I installed LibreOffice Base and make Newdb.odb, a names table, and a names report .
#yum install libreoffice-base
$libreoffice --base

But The Base outputed next messge, and I could not see the report .

"
The document "names" could not be opend .

Can not active the factory for
org.libreoffice.report.pentaho.SOReportJobFactory$_SOReportJobFactory
because java.lang.NoClassDefFoundError:
org/apache/commons/logging/LogFactory
"

I attached Newdb.odb, and base.strace.txt .



Version-Release number of selected component (if applicable):
libreoffice-base-4.1.0.1-8.fc19.x86_64

How reproducible: always

Steps to Reproduce:
1. Open Newdb.odb .
2. select Reports .
3. Double click "names" report .


Actual results:
The Base outputed a message, and could not see the report .

Expected results:
The Base should output the report .

Additional info:
Comment 1 David Tardon 2013-07-12 02:45:40 EDT
I forgot to merge report-builder deps into base.
Comment 2 Will Kemp 2013-07-18 20:18:56 EDT
Any suggestions for a workaround?

And any estimate of when a fixed package will be released?

I've got a job i need to do with this and i need to decide whether i have to find another way to do it or not.

Thanks
Comment 3 David Tardon 2013-07-19 00:59:17 EDT
I am doing an update today. Workaround is to install pentaho-reporting-flow-engine package.
Comment 4 Will Kemp 2013-07-19 01:07:48 EDT
Thanks mate!
Comment 5 David Tardon 2013-07-19 07:59:01 EDT
There is ongoing outage of the build infrastructure, so it will have to wait till tomorrow, I am afraid.

Note You need to log in before you can comment on or make changes to this bug.