Bug 983833 - fedup does nothing during upgrade
fedup does nothing during upgrade
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
18
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 00:16 EDT by J. Neto
Modified: 2013-10-09 16:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 16:56:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. Neto 2013-07-12 00:16:33 EDT
Description of problem:
fedup does nothing during upgrade. fedup downloads all packages and exits successfully, but running System Upgrade does nothing, only cleans all fedup related things.

Version-Release number of selected component (if applicable):
fedup-0.7.3-4.fc18.noarch

How reproducible:
Always. 

Sincerely, I've tried only 2 times. 13GB download is too much.

Steps to Reproduce:
1. fedup-cli --network 19
2. cp /etc/grub2.cfg /boot/grub2/grub.cfg
3. Reboot and "System Upgrade"

Actual results:
"System Upgrade" persists in grub, but now gives an error: initrd-fedup not found. Like I've said, all fedup related previously downloaded things are gone (deleted) now.

I'm still in Fedora 18.

Expected results:

Upgrade to Fedora 19.

Additional info:

Here are the last words of fedup.log:

[     2.734] (II) fedup:<module>() /usr/bin/fedup-cli starting at Thu Jul 11 01:21:56 2013
[     2.892] (II) fedup.sysprep:remove_cache() removing /var/tmp/fedora-upgrade
[     4.055] (II) fedup.sysprep:remove_cache() removing /var/lib/fedora-upgrade
[    44.089] (II) fedup.sysprep:remove_cache() removing /var/tmp/fedora-upgrade
[    44.089] (II) fedup.sysprep:remove_cache() removing /var/lib/fedora-upgrade
[    44.089] (II) fedup.sysprep:misc_cleanup() removing symlink /system-upgrade
[    44.090] (II) fedup.sysprep:misc_cleanup() removing /system-upgrade-root
[    44.108] (II) fedup.sysprep:misc_cleanup() removing /lib/systemd/system/system-upgrade.target.wants
[    44.108] (II) fedup:<module>() /usr/bin/fedup-cli exiting at Thu Jul 11 01:22:37 2013
Comment 1 J. Neto 2013-07-12 09:31:54 EDT
In my 2 attempts,  I never stayed in front of PC to see all the upgrade process. I know that they run very quickly - about 15min. Maybe the same issue above.
Comment 2 J. Neto 2013-09-05 18:39:10 EDT
Tried again and... mysteriously everything gone fine.

I think my notebook was having power failures - but this not explains the removed files.
Comment 3 Will Woods 2013-10-09 16:56:44 EDT
I can't explain that either, but if you aren't having the problem anymore then there's not much I can do.

Note You need to log in before you can comment on or make changes to this bug.