Bug 983834 - Scroll don't work with wheel mouse on gedit with kde
Scroll don't work with wheel mouse on gedit with kde
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 00:19 EDT by dominique
Modified: 2015-06-15 23:18 EDT (History)
15 users (show)

See Also:
Fixed In Version: gtk3-3.10.6-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1043264 (view as bug list)
Environment:
Last Closed: 2013-12-13 22:23:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Snippet of strace output (282.78 KB, text/plain)
2013-08-22 12:50 EDT, Shawn Q
no flags Details
gdkdevicemanager-xi2.diff (1.05 KB, patch)
2013-11-10 03:05 EST, dominique
no flags Details | Diff

  None (edit)
Description dominique 2013-07-12 00:19:11 EDT
I install F19 with Kde, but I prefer gedit.
I install but the scroll with whell mouse in gedit windows don't work.
Scroll only work if the pointer of the mouse is on the elevator in the right of window.

With F18, kde and gedit, wheel mouse scroll work in gedit window.

It's a bug or a feature ?
Comment 1 Clauber 2013-07-15 03:19:15 EDT
Description of problem: 
Mouse wheel doesn't work with gtk apps.
It works only if you press 3th button (middle), but it'll paste a clipboard content in the text before scroll.
This happened after install F19 (new install). At F18 worked fine!


Version-Release number of selected component (if applicable): 
2.2.4


Steps to Reproduce:
1. Open a file.
2. Move the mouse wheel.

Actual results:
Doesn't scroll the page.

Expected results:
Scrolls the page.

Additional info:

./configure  '--build=i686-redhat-linux-gnu' '--host=i686-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/var/lib' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--disable-dependency-tracking' '--disable-static' '--disable-update-databases' '--disable-xml-catalog-update' '--docdir=/usr/share/doc/bluefish-2.2.4' 'build_alias=i686-redhat-linux-gnu' 'host_alias=i686-redhat-linux-gnu' 'CFLAGS=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables' 'LDFLAGS=-Wl,-z,relro '
gtk 3.7.8 (runtime gtk 3.8.2)
glib 2.35.7 (runtime 2.36.3)
with libenchant... yes
with libenchant >= 1.4... yes
with libgucharmap... no
with libgucharmap_2... yes
with python... yes
Comment 2 dominique 2013-07-15 08:51:22 EDT
(In reply to Clauber from comment #1)
> Description of problem: 
> Mouse wheel doesn't work with gtk apps.
> It works only if you press 3th button (middle), but it'll paste a clipboard
> content in the text before scroll.
> This happened after install F19 (new install). At F18 worked fine!
> 
> 
> Version-Release number of selected component (if applicable): 
> 2.2.4
> 
> 
> Steps to Reproduce:
> 1. Open a file.
> 2. Move the mouse wheel.
> 
> Actual results:
> Doesn't scroll the page.
> 
> Expected results:
> Scrolls the page.
> 
> Additional info:
> 
> ./configure  '--build=i686-redhat-linux-gnu' '--host=i686-redhat-linux-gnu'
> '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin'
> '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share'
> '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec'
> '--localstatedir=/var' '--sharedstatedir=/var/lib' '--mandir=/usr/share/man'
> '--infodir=/usr/share/info' '--disable-dependency-tracking'
> '--disable-static' '--disable-update-databases'
> '--disable-xml-catalog-update' '--docdir=/usr/share/doc/bluefish-2.2.4'
> 'build_alias=i686-redhat-linux-gnu' 'host_alias=i686-redhat-linux-gnu'
> 'CFLAGS=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
> -fstack-protector --param=ssp-buffer-size=4  -m32 -march=i686 -mtune=atom
> -fasynchronous-unwind-tables' 'LDFLAGS=-Wl,-z,relro '
> gtk 3.7.8 (runtime gtk 3.8.2)
> glib 2.35.7 (runtime 2.36.3)
> with libenchant... yes
> with libenchant >= 1.4... yes
> with libgucharmap... no
> with libgucharmap_2... yes
> with python... yes

Ok I test by press on mouse wheel and scroll and that work.

But if you don't press, that don't work...
Comment 3 nicofo 2013-07-17 16:48:03 EDT
I can confirm this bug, apparently with any gtk application in KDE (at least with gedit and gnote).
Bug present in Fedora 19 and not in Fedora 18.

Fedora 18: GNOME 3.6  GEDIT 3.6.2  KDE 4.10.4
Fedora 19: GNOME 3.8  GEDIT 3.8.3  KDE 4.10.5
-> the problems seems coming from gnome (3.6 -> 3.8) and not KDE (no major update)
Comment 4 dominique 2013-08-07 02:21:45 EDT
A little up...
Nobody know how solve this problem ?
Comment 5 Shawn Q 2013-08-22 12:48:18 EDT
I upgraded Fedora KDE Spin x86_64 from 18 to 19 a little over a week ago and gedit was working fine up until yesterday/the day before, I think there was an update that broke this mouse scroll wheel functionality in gtk apps.  

Saw these errors popping up in konsole when running it, don't know if it's related:

(gedit:16858): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

Tried installing gnome-session / gnome-session-xsession, haven't had any success fixing this mouse wheel issue or Gtk-Warning. 

It's funny how the smallest thing can be such a pain in the rear end - I use gedit constantly all throughout the day.

When I run an strace -v -s255 on gedit, I notice a bunch of (Resource temporarily unavailable) events pop up when I try to scroll the mouse wheel, not sure if this helps.

Will try to attach snippet during mouse wheel scroll action.
Comment 6 Shawn Q 2013-08-22 12:50:51 EDT
Created attachment 789273 [details]
Snippet of strace output

This is "strace -v -s255" for gedit during mouse wheel scroll action. Please note, this block of output may also include window focus in/out, and other events.
Comment 7 Steven P. Ulrick 2013-09-16 13:40:48 EDT
Same here.  When I upgraded (fedup) from Fedora 17 to Fedora 19, turning my mouse wheel no longer caused the expected scrolling...
Comment 8 williamroot777 2013-09-24 05:06:01 EDT
I have the same situation, almost ALL the GTK applications under KDE,transmission-gtk,audacious. However, it seems that eclipse and firefox works fine.
Comment 9 Jochen Meissner 2013-10-15 16:45:24 EDT
I can report the same issue for Bluefish Editor with a Kensington Trackball after "fedup-ing" from Fedora 17 to 19.  The scrolling wheel works in some applications i.e. Thunderbird, not in others.
Comment 10 Valmir Pimenta 2013-11-08 13:52:33 EST
I have the same situation here. Seems like it is a gnome gtk issue, since it is affecting Ubuntu with Unity and XFCE boxes too. They issued a patch tough:

https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1171342
Comment 11 dominique 2013-11-08 14:53:49 EST
(In reply to Valmir Pimenta from comment #10)
> I have the same situation here. Seems like it is a gnome gtk issue, since it
> is affecting Ubuntu with Unity and XFCE boxes too. They issued a patch tough:
> 
> https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1171342

I don't find the patch, where is it ?
Comment 12 Valmir Pimenta 2013-11-08 15:28:57 EST
(In reply to dominique from comment #11)
> (In reply to Valmir Pimenta from comment #10)
> > I have the same situation here. Seems like it is a gnome gtk issue, since it
> > is affecting Ubuntu with Unity and XFCE boxes too. They issued a patch tough:
> > 
> > https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1171342
> 
> I don't find the patch, where is it ?

It's mentioned in a link about a PPA that points here:

https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1171156

I believe the relevant bits are under:

https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1171156/comments/11

But the patch itself was done upstream. Sorry, don't have a poiter to the patch proper.
Comment 13 dominique 2013-11-09 01:08:58 EST
I find the patch here : https://launchpadlibrarian.net/138037691/gtk%2B3.0_3.6.4-0ubuntu7_3.6.4-0ubuntu8.diff.gz

but I look into the gtk3.3.8.6-1 source, and the patch is already in use...
Comment 14 dominique 2013-11-09 02:10:58 EST
For test I rebuild gtk3.3.8.6-1 without the debian patch, and after install scroll work well in gedit.

I am not a dev or a programmer, and I don't know if it's a good way.

If that help you.
Comment 15 dominique 2013-11-10 01:12:53 EST
I think it's a problem with gtk3, also I re-assign this bug to gtk3
Comment 16 dominique 2013-11-10 03:04:05 EST
I join the diff, with I rebuild gtk3.3.8.6-1
Comment 17 dominique 2013-11-10 03:05:38 EST
Created attachment 822042 [details]
gdkdevicemanager-xi2.diff
Comment 18 dominique 2013-11-11 01:55:07 EST
If anybody want test, I upload the rpms here : 
https://mega.co.nz/#!gdkkSZQb!BAf66XHAFx2SNx1uhKPeCSNgjas-EQzBleSWaKXkFLs
Comment 19 Steven P. Ulrick 2013-11-11 04:50:18 EST
Those RPM's fix the problem for me.  On Easytag, Bluefish, Geeqie & GIMP scrolling with the mouse wheel now works perfectly!
Comment 20 dominique 2013-11-12 00:49:43 EST
There is no dev for gtk3 on this bug ?

The debian patch is upstream, may be I send this bug to ghome bugzilla ?
Comment 21 nicofo 2013-11-12 14:23:23 EST
Thank you, these RPM fix the problem (successfully tested in gnote and gedit in KDE).
Hope they will be integrated soon in Fedora repos...
Comment 22 Valmir Pimenta 2013-11-12 14:55:31 EST
Thanks. The RPMs fixed the problem here too.
Comment 23 Adam Williamson 2013-11-15 18:11:30 EST
"The debian patch is upstream, may be I send this bug to ghome bugzilla ?"

Yes, I would recommend doing that.
Comment 24 dominique 2013-11-16 01:23:08 EST
Ok Adam, I feel this bug to gnome bugzilla : https://bugzilla.gnome.org/show_bug.cgi?id=712174

I think all users here should register for this bug.
Comment 25 dominique 2013-11-19 01:54:14 EST
The gnome bug 712174 is duplicate of gnome bug 699574 : https://bugzilla.gnome.org/show_bug.cgi?id=699574

There is a proposed patch in comment 5, and for test I rebuild gtk3 with this patch.
That work for me, and if you want test , I upload rpms here : https://mega.co.nz/#!EBE1gA7T!FQUnHBw1M8M3ZeUZ-DJeaAuBTQ1aSTS0ISDvUZbirgQ
Comment 26 dominique 2013-11-19 03:59:05 EST
The bug is also present on fedora20 beta and gtk3 3.10.
I rebuild with the same patch in comment 25, and gedit work fine, scroll work.
Comment 27 Shawn Q 2013-11-20 12:56:21 EST
I can also confirm your x86_64 RPM's worked great for me in Fedora 19, dominique, as per https://bugzilla.redhat.com/show_bug.cgi?id=983834#c25

Thank you so much!
Comment 28 dominique 2013-12-05 06:22:25 EST
Problem seem solve in Fedora 21-rawhide with gtk3-3.11.2-1-fc21, scrool work with gedit. 

I don't know if that version of gtk3 will be in Fedora 20.
Comment 29 dominique 2013-12-05 06:35:28 EST
Good new, package gtk3-3.8.8-2.fc19 solve problem for me, scroll work with gedit.

I think it's will be in updates soon, otherwise it's in koji : http://koji.fedoraproject.org/koji/buildinfo?buildID=482831
Comment 30 Adam Williamson 2013-12-05 13:10:47 EST
http://koji.fedoraproject.org/koji/buildinfo?buildID=482840 likely fixes it for F20 too. The fix won't go into the final release, but it will be available as a 0-day update, I expect.
Comment 31 Fedora Update System 2013-12-05 14:53:56 EST
gtk3-3.10.6-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gtk3-3.10.6-1.fc20
Comment 32 Fedora Update System 2013-12-05 16:29:26 EST
Package gtk3-3.10.6-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gtk3-3.10.6-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22830/gtk3-3.10.6-1.fc20
then log in and leave karma (feedback).
Comment 33 Fedora Update System 2013-12-13 22:23:13 EST
gtk3-3.10.6-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 34 buzire.rhn 2014-01-02 06:50:27 EST
Scrolling still doesn't work properly when the window is not focused.

Steps to reproduce:
1. Open a gedit window with a long file (scroll on it to see the proper behaviour).
2. Open a different window alongside.
3. Click on the second window to focus it.
4. Place mouse cursor over gedit window (don't click!).
5. Try scrolling.

Symptoms:
Mouse scroll has no effect, touchpad scroll is jerky.

Desired effect:
Scrolling works the same way as when window is focused (i.e. touchpad=smooth, mouse scroll=works).
Comment 35 Erik Johnson 2015-04-13 00:46:22 EDT
Mouse scrolling does not work when any window has higher z-order than gEdit, this means system pop-up notifications (kde) like new mail, new rss item, download complete, etc, even though gEdit still has focus, prevents the scroll wheel from functioning in gEdit unless I hold down the left button (selecting text all the while).  If I click the notification to make it go away scroll functionality returns.

Note You need to log in before you can comment on or make changes to this bug.