Bug 983851 - hypervkvpd: Fix a bug in IPV6 subnet enumeration
hypervkvpd: Fix a bug in IPV6 subnet enumeration
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hypervkvpd (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomáš Hozza
Virtualization Bugs
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 02:15 EDT by Tomáš Hozza
Modified: 2013-11-20 23:52 EST (History)
6 users (show)

See Also:
Fixed In Version: hypervkvpd-0-0.12.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 23:52:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upstream patch (951 bytes, patch)
2013-07-12 04:39 EDT, Tomáš Hozza
no flags Details | Diff

  None (edit)
Description Tomáš Hozza 2013-07-12 02:15:51 EDT
Description of problem:
I got an email from upstream maintainer:

Thomas,

Please pickup this patch for both RHEL 6.4 and RHEL 6.5. Without
this patch IP GET functionality will not work on ws2012 R2 (Windows Blue).

Thank you,

K. Y

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Tomáš Hozza 2013-07-12 02:18:16 EDT
I got the patch from upstream maintainer, but would rather wait couple of days
till it's accepted upstream.
Comment 2 Tomáš Hozza 2013-07-12 04:39:11 EDT
Created attachment 772574 [details]
upstream patch
Comment 3 Tomáš Hozza 2013-07-12 04:40:43 EDT
K.Y.

Can you please help us with how to test this issue? Thank you!
Comment 4 RHEL Product and Program Management 2013-07-12 06:50:06 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 5 K. Y. Srinivasan 2013-07-12 07:34:38 EDT
The bug was exposed when testing on the about to be released ws2012 r2. The following command executed from a power shell window (opened with admin rights):

Get-VMNetworkAdapter -VMName name_of_the_vm

You will see that without this patch, the IP addresses will not be listed. I am assuming here that you have already picked up the kernel vmbus patch that correctly negotiates the protocol version.
Comment 6 lijing 2013-07-15 06:47:38 EDT
we QE have reproduced this bug with WS 2012 R2

version info:
host: Windows Server 2012 R2
guest: RHEL6.4(2.6.32-358.el6.x86_64)
hypervkvpd: hypervkvpd-0-0.9.el6

the step as below:

1. install RHEL6.4 guest
2. check the hypervkvpd status
#service hypervkvpd status
3.Check that the SELinux is enabled on the guest
4. run the command below on host
#Get-VMNetworkAdapter -VMName name_of_the_vm |ft ipaddresses
Comment 9 lijing 2013-09-13 03:46:56 EDT
verify this bug , install RHEL6.5 x86_64 and i386 guest on WS 2012 R2, the kernel of which is 2.6.32-415.0.1.el6.x86_64/2.6.32-415.0.1.el6.i686 with hypervkvpd-0-0.12.el6.x86_64/hypervkvpd-0-0.12.el6.686 , get correct IP information from guest .
Comment 11 errata-xmlrpc 2013-11-20 23:52:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1539.html

Note You need to log in before you can comment on or make changes to this bug.