Bug 98389 - apacectl configtest does not parse included config files
Summary: apacectl configtest does not parse included config files
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache   
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-02 09:33 UTC by Toni Willberg
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 10:31:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Toni Willberg 2003-07-02 09:33:07 UTC
redhat-release-7.2-1
apache-1.3.27-1.7.2

Hi.

I know that 7.2 is old, but still so widely used that there's big chance that
others run into this same problem as I did. I did not test this problem with
other releases.

Also, I realize the problem is in upstream, but RH has better chances to patch
it than me. ;)

RedHat's initfile for httpd uses apachectl for "configtest" option. Perhaps it
should use "httpd -S" command instead?


1) Include something from httpd.conf:
 Include /tmp/httpd-cust.conf

2) Put some crap to give file:
 FooBarCommand blaablaa

3a) $service httpd configtest
Syntax OK
3b) $apachectl configtest
Syntax OK

4) $httpd -S
Syntax error on line nn of /tmp/httpd-cust.conf:
Invalid command 'FooBarCommand', perhaps mis-spelled or defined by a module not
included in the server configuration

Comment 1 Bishop Clark 2003-10-19 07:58:49 UTC
I'm seeing it on RH9, too, FWIW.

Comment 2 Bishop Clark 2004-01-27 04:43:45 UTC
Should we open a MeToo bug for RHL9 or what?

Comment 3 Nalin Dahyabhai 2004-01-30 17:14:45 UTC
Updating RHL version to 9.

Comment 4 Joe Orton 2004-09-21 10:31:36 UTC
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.




Note You need to log in before you can comment on or make changes to this bug.