Bug 98392 - guile SRFI-13 not included
Summary: guile SRFI-13 not included
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: guile   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-02 10:59 UTC by Han-Wen Nienhuys
Modified: 2015-03-05 01:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-19 14:03:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Han-Wen Nienhuys 2003-07-02 10:59:36 UTC
Description of problem:

Loading SRFI-13 (the string library) gives the following error message.

guile> byrd:~/usr/src/lilypond$ /usr/bin/guile
guile>  (use-modules (srfi srfi-13))
/usr/share/guile/1.6/srfi/srfi-13.scm:159:1: In procedure dynamic-link in
expression (load-extension "libguile-srfi-srfi-13-14-v-1" "scm_init_srfi_13"):
/usr/share/guile/1.6/srfi/srfi-13.scm:159:1: file:
"libguile-srfi-srfi-13-14-v-1", message: "libguile-srfi-srfi-13-14-v-1.so:
cannot open shared object file: No such file or directory"
ABORT: (misc-error)

Type "(backtrace)" to get more information or "(debug)" to enter the debugger.
guile>  (version)
"1.6.4"
guile> byrd:~/usr/src/lilypond$ rpm -q guile
guile-1.6.4-6.2


(note that this also doesn't work on RH9, which ships guile 1.6.0)

This is caused by the following line in the Spec file:

  # Remove unpackaged files
  ....
  rm -rf ${RPM_BUILD_ROOT}%{_libdir}/libguile-srfi-srfi-*

I suggest this is removed from the .spec, and the libguile-srfi-srfi-*
be added to the %files section.

I'm marking this bug as severe. I am about to release lilypond 1.8 (a new stable
branch), and it would be nice if -for the first time in 4 years- this release
does not require recompiling stuff on the stock RedHat distro.

Comment 1 Phil Knirsch 2003-07-02 12:50:25 UTC
Pakcage guile-1.6.4-7 and later contains the srfi libs.

Read ya, Phil

Comment 2 Han-Wen Nienhuys 2003-08-19 13:50:27 UTC
guile-devel-1.6.4-7.1 does contain the .so files ; this is an
error, they should be in the guile run-time package.



Comment 3 Phil Knirsch 2003-08-19 14:03:33 UTC
OK, fixed. Also moved the readline libs, were in devel, too.

guile-1.6.4-8 and later have the fix.

Read ya, phil



Note You need to log in before you can comment on or make changes to this bug.