Bug 983922 - Review Request: compat-SFML16 - Simple and Fast Multimedia Library
Review Request: compat-SFML16 - Simple and Fast Multimedia Library
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 05:46 EDT by Hans de Goede
Modified: 2013-07-27 21:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: compat-SFML16-1.6-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-27 21:05:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
i: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2013-07-12 05:46:49 EDT
Spec URL: http://people.fedoraproject.org/~jwrdegoede/compat-SFML16.spec
SRPM URL: http://people.fedoraproject.org/~jwrdegoede/compat-SFML16-1.6-1.fc19.src.rpm
Description: 
SFML is a portable and easy to use multimedia API written in C++. You can see
it as a modern, object-oriented alternative to SDL.
SFML is composed of several packages to perfectly suit your needs. You can use
SFML as a minimal windowing system to interface with OpenGL, or as a
fully-featured multimedia library for building games or interactive programs.

Fedora Account System Username: jwrdegoede

Note there are no Obsoletes / Provides for SFML, since SFML will live on and move to 2.0 applications linked to SFML-1.6 will automatically drag in compat-SFML16 based on soname deps. Applications which build against SFML-1.6 will need to update their BuildRequires.
Comment 1 Christopher Meng 2013-07-15 20:41:52 EDT
Hi,

Can I approve it now?

I think this is just a reuse, should be no problem here.
Comment 2 Hans de Goede 2013-07-16 02:59:55 EDT
Hi,

(In reply to Christopher Meng from comment #1)
> Hi,
> 
> Can I approve it now?
> 
> I think this is just a reuse, should be no problem here.

Only people which are official Fedora packagers can approve review-requests, and since you need to ask how to review process work I assume you're not an official packager (yet). If you want to become one see:
https://fedoraproject.org/wiki/Join_the_package_collection_maintainers

Regards,

Hans
Comment 3 Christopher Meng 2013-07-16 03:41:35 EDT
;D
Comment 4 Hans de Goede 2013-07-16 04:35:47 EDT
(In reply to Christopher Meng from comment #3)
> ;D

Hehe, thanks.
Comment 5 Hans de Goede 2013-07-16 05:01:12 EDT
New Package SCM Request
=======================
Package Name: compat-SFML16
Short Description: Simple and Fast Multimedia Library
Owners: jwrdegoede belegdol
Branches: f19
InitialCC:
Comment 6 Gwyn Ciesla 2013-07-16 08:11:36 EDT
Git done (by process-git-requests).
Comment 7 Fedora Update System 2013-07-18 06:47:22 EDT
compat-SFML16-1.6-1.fc19,SFML-2.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/compat-SFML16-1.6-1.fc19,SFML-2.0-2.fc19
Comment 8 Fedora Update System 2013-07-20 05:39:32 EDT
Package compat-SFML16-1.6-1.fc19, SFML-2.0-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing compat-SFML16-1.6-1.fc19 SFML-2.0-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13257/compat-SFML16-1.6-1.fc19,SFML-2.0-2.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-07-27 21:05:41 EDT
compat-SFML16-1.6-1.fc19, SFML-2.0-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.