Bug 983936 - blitwizard engine run in wine crashes X server
blitwizard engine run in wine crashes X server
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 06:45 EDT by Jonas Thiem
Modified: 2013-10-10 17:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 17:38:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glxinfo output (14.13 KB, text/plain)
2013-07-12 06:45 EDT, Jonas Thiem
no flags Details
Xorg.0.log with crash backtrace (43.49 KB, text/plain)
2013-07-12 06:46 EDT, Jonas Thiem
no flags Details
blitwizard in the offending version (3.64 MB, application/zip)
2013-07-12 06:48 EDT, Jonas Thiem
no flags Details
Wine output before crashing X (90.39 KB, text/plain)
2013-07-13 08:53 EDT, Jan Philipp Timme
no flags Details
Xorg log containing AIGLX-error + Backtrace (29.91 KB, text/plain)
2013-07-13 09:10 EDT, Jan Philipp Timme
no flags Details

  None (edit)
Description Jonas Thiem 2013-07-12 06:45:09 EDT
Created attachment 772628 [details]
glxinfo output

Description of problem:
A windows program (blitwizard engine + demos) run in wine crashes the whole X server. See steps to reproduce & attached X log.

Version-Release number of selected component (if applicable):

X.Org X Server 1.14.1
Release Date: 2013-04-17
X Protocol Version 11, Revision 0
Build Operating System:  2.6.32-358.2.1.el6.x86_64 
Current Operating System: Linux jth.lan 3.9.9-301.fc19.x86_64 #1 SMP Thu Jul 4 15:10:36 UTC 2013 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-3.9.9-301.fc19.x86_64 root=UUID=e9cf87cc-c540-4aef-9046-283d0ac2962d ro rootflags=subvol=root rd.luks.uuid=luks-2b1b1687-f448-47ef-ba40-bf7b49b3c00a rd.md=0 rd.lvm=0 rd.dm=0 vconsole.font=latarcyrheb-sun16 vconsole.keymap=de rhgb quiet LANG=en_US.UTF-8
Build Date: 05 June 2013  10:30:19PM
Build ID: xorg-x11-server 1.14.1-4.fc19 
Current version of pixman: 0.30.0
(glxinfo is attached)
wine is: wine-1.6-rc2
xorg-x11-drv-intel is: 2.21.8-1.fc19

How reproducible:
100% on this laptop

Steps to Reproduce:
1. Fetch http://www.blitwizard.de/jenkins/job/blitwizard/Deps=static,Platform=win32/lastSuccessfulBuild/artifact/blitwizard-0.4-windows.zip
2. Unzip somewhere, then cd into the resulting "blitwizard-0.4" folder
3. Run this command: wine bin/blitwizard.exe -changedir bin/

Actual results:
Instant X crash

Expected results:
X continues to run normally, application crash in case the application is buggy (but not X crash)

Additional info:
I authored that program, so maybe I can provide some help debugging. I'm not very familiar with SDL2 internals though, which I use for drawing and which probably triggers this crash in combination with wine. The native linux version of blitwizard runs just fine. The program is open-source, if the program source is of any help
Comment 1 Jonas Thiem 2013-07-12 06:46:12 EDT
Created attachment 772629 [details]
Xorg.0.log with crash backtrace
Comment 2 Jonas Thiem 2013-07-12 06:48:38 EDT
Created attachment 772630 [details]
blitwizard in the offending version

Since the upload file limit appears to allow me to do it, I'll also upload the offending program.
Comment 3 Jan Philipp Timme 2013-07-13 08:53:15 EDT
Created attachment 773034 [details]
Wine output before crashing X

Wine stderr output captured using WINEDEBUG=warn+all and LANG=C
$ wine blitwizard.exe 2>logfile

Version: wine-1.6-rc2 (from Fedora 19 official package)
Reproduced on a fresh Fedora 19 installation in a VirtualBox without 3D acceleration enabled
Comment 4 Jan Philipp Timme 2013-07-13 09:10:05 EDT
Created attachment 773036 [details]
Xorg log containing AIGLX-error + Backtrace

Another Xorg logfile from my VirtualBox Fedora containing error+backtrace.
Comment 5 Jonas Thiem 2013-07-13 18:02:15 EDT
I filed a bug report on bugs.freedesktop.org at https://bugs.freedesktop.org/show_bug.cgi?id=66882
Comment 6 Jonas Thiem 2013-10-10 17:38:24 EDT
With X.Org X Server 1.14.3 I can no longer reproduce this. It was probably fixed in some of the updates.

Note You need to log in before you can comment on or make changes to this bug.