Bug 983965 - 3.7.3. Needs several changes
3.7.3. Needs several changes
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Lucas Costi
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 08:05 EDT by Pavel Janousek
Modified: 2014-08-14 11:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.11 Build Name: 6895, Installation Guide-6.1-2 Build Date: 11-07-2013 14:10:24 Topic ID: 13443-377329 [Specified]
Last Closed: 2013-10-22 21:26:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Janousek 2013-07-12 08:05:54 EDT
Title: Install Patches in zip form

Describe the issue:


Suggestions for improvement:
1. Documentation is for EAP6, there aren't several product of EAP6, so I don't like to read that patch ZIP is distributed for all product and RPM only for subset of them.

2. It isn't true bug fixes aren't distributed in RPM. This policy was in the past, but right now, it depends on triage by PM and GSS. It is true not every OneOff ZIP patch is distributed by RPM as well, but RPM way isn't limited to secitury fixes only.

3. Procedure 3.13. I'm not native speaker, moreover erratum/errata comes from Latina, but as far as I know, erratum is one concrete fix, so you can't mention 'Erratum' as 'list of resolved flaws' because in this case it becomes 'Errata'. I prefer to use 'Errata' in every a such places.

4. Procedure 3.13. again - step 5 is outdated. Right now every ZIP patch contains:
- README
- modules.xml
- patched jar(s)

In the existing instance modules.xml is the only one file which is replaced after unziping. JAR(s) filenames contains BZ number in the name and in that case can't rewrite older files on disk.
Comment 4 Lucas Costi 2013-10-22 21:26:12 EDT
The entire section for zip patching is being replaced in 6.2 with the new patching system. It isn't onstage yet, but will be in the next build. It can be previewed on docbuilder here: http://docbuilder.usersys.redhat.com/14873/#sect-Install_Patches_in_Zip_Form

Note You need to log in before you can comment on or make changes to this bug.