Bug 983999 - rhn-client-tools + sosreport = crash
rhn-client-tools + sosreport = crash
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
6.6
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Milan Zázrivec
Lukas Pramuk
:
: 982147 1004112 (view as bug list)
Depends On:
Blocks: 1041770
  Show dependency treegraph
 
Reported: 2013-07-12 09:43 EDT by Matej Kollar
Modified: 2015-08-26 10:13 EDT (History)
20 users (show)

See Also:
Fixed In Version: rhn-client-tools-1.0.0.1-10-el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1041770 (view as bug list)
Environment:
Last Closed: 2013-11-21 18:15:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 506353 None None None Never

  None (edit)
Description Matej Kollar 2013-07-12 09:43:25 EDT
Description of problem:

  sosreport on RHEL6 calls

    "python /usr/share/rhn/up2date_client/hardware.py",

  which leads to crash (hidden, caught by abrt, but crashreport
  is usually immediately deleted with

    Corrupted or bad directory '/var/spool/abrt/pyhook-2013-07-09-11:40:06-27058', deleting

  see Bug 909617.
  Coliding name rpmUtils resolves to one in /usr/share/rhn/up2date_client/
  (that do not have submodule transaction) instead of
  the one in /usr/lib/python2.6/site-packages/rpmUtils/.

Version-Release number of selected component (if applicable):
  sos-2.2-38.el6.noarch
  rhn-client-tools-1.10.11-1.el6.noarch

How reproducible: always deterministic

Steps to Reproduce:
  1. python /usr/share/rhn/up2date_client/hardware.py

Actual results:
  Trace...
  >   File "/usr/share/rhn/up2date_client/hardware.py", line 24, in <module>
  >     import rhnserver
  >   File "/usr/share/rhn/up2date_client/rhnserver.py", line 34, in <module>
  >     import rpcServer
  >   File "/usr/share/rhn/up2date_client/rpcServer.py", line 12, in <module>
  >     import clientCaps
  >   File "/usr/share/rhn/up2date_client/clientCaps.py", line 10, in <module>
  >     from capabilities import parseCap
  >   File "/usr/share/rhn/up2date_client/capabilities.py", line 4, in <module>
  >     import up2dateErrors
  >   File "/usr/share/rhn/up2date_client/up2dateErrors.py", line 44, in <module>
  >     from yum.Errors import YumBaseError
  >   File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 52, in <module>
  >     import config
  >   File "/usr/lib/python2.6/site-packages/yum/config.py", line 40, in <module>
  >     import rpmUtils.transaction
  > ImportError: No module named transaction

Expected results:

  Info about hardware is printed.

Additional info:

  Might be related to patch 1417f0700405f27f13309d12fc41603fd37b72a4.
Comment 2 Olle Eriksson 2013-08-06 15:52:27 EDT
Downgrading rhn-client-tools from  1.0.0.1-8 to 1.0.0.0-4 restores
a working system
Comment 4 Tomas Lestach 2013-08-14 04:11:45 EDT
Putting the 1st element of the python search path to the end

    keeping content of search path, changing just the order for finding yum
    rpmUtils module instead of our one in the working directory
    (not a nice solution)


spacewalk.git: 7a6914a28bb5ef2e7a721be91b81a94979dbdcfa
Comment 7 Milan Zázrivec 2013-09-04 05:50:25 EDT
*** Bug 1004112 has been marked as a duplicate of this bug. ***
Comment 8 Jan Hutař 2013-10-15 03:50:37 EDT
*** Bug 982147 has been marked as a duplicate of this bug. ***
Comment 15 Lukas Pramuk 2013-10-29 08:08:04 EDT
VERIFIED. rhn-client-tools-1.0.0.1-16.el6.noarch

REPRO:
# python /usr/share/rhn/up2date_client/hardware.py
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/hardware.py", line 25, in <module>
    import rhnserver
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 22, in <module>
    import rpcServer
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 12, in <module>
    import clientCaps
  File "/usr/share/rhn/up2date_client/clientCaps.py", line 10, in <module>
    import capabilities
  File "/usr/share/rhn/up2date_client/capabilities.py", line 4, in <module>
    import up2dateErrors
  File "/usr/share/rhn/up2date_client/up2dateErrors.py", line 16, in <module>
    from yum.Errors import RepoError, YumBaseError
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 52, in <module>
    import config
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 40, in <module>
    import rpmUtils.transaction
ImportError: No module named transaction

vs.

FIX:
# python /usr/share/rhn/up2date_client/hardware.py
'bus' : 'pci'
'driver' : 'x38_edac'
'pciType' : '1'
'prop4' : '1308'
'prop1' : '8086'
'prop2' : '29E0'
'prop3' : '103C'
'detached' : '0'
'class' : 'OTHER'
'desc' : 'Intel Corporation|82X38/X48 Express DRAM Controller'

'bus' : 'pci'
'driver' : 'pcieport'
'pciType' : '1'
'prop4' : '0000'
'prop1' : '8086'
'prop2' : '29E1'
'prop3' : '0000'
'detached' : '0'
'class' : 'OTHER'
'desc' : 'Intel Corporation|82X38/X48 Express Host-Primary PCI Express Bridge'

'bus' : 'pci'
'driver' : 'nouveau'
'pciType' : '1'
'prop4' : '0492'
'prop1' : '10DE'
'prop2' : '042F'
'prop3' : '10DE'
'detached' : '0'
'class' : 'VIDEO'
'desc' : 'NVIDIA Corporation|G86 [Quadro NVS 290]'

...
Comment 19 errata-xmlrpc 2013-11-21 18:15:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1702.html

Note You need to log in before you can comment on or make changes to this bug.