Bug 984004 - Adding more than two workflow pattern breaks the editor.
Adding more than two workflow pattern breaks the editor.
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER6
: 6.0.0
Assigned To: Tihomir Surdilovic
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 09:51 EDT by Marek Baluch
Modified: 2014-08-06 16:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:13:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot1 (252.46 KB, image/png)
2013-07-12 09:51 EDT, Marek Baluch
no flags Details

  None (edit)
Description Marek Baluch 2013-07-12 09:51:49 EDT
Created attachment 772711 [details]
Screenshot1

Description of problem
----------------------
When more than workflow patterns is added to the editor then the editor will stop accepting input.

No more activities can be added no control commands can be used. E.g. Screenshot1.png shows what happens on Ctrl+a.


How to reproduce
----------------
1) add 'MI Without Synchronization'
2) append 'Implicit Termination'
3) try any other operation (e.g. ctrl+a, mouse multiple select, etc.)
Comment 1 Marek Baluch 2013-07-12 10:25:17 EDT
Found in DR6 (Beta5).
Comment 2 Kris Verlaenen 2013-09-16 13:54:31 EDT
Since it is unlikely this will affect a lot of users, I do not consider this a beta blocker.
Comment 3 Prakash Aradhya 2013-09-16 17:19:08 EDT
Internal Whiteboard: Beta Blocker → Blocker
Not critical for Beta, but need to address for GA
Comment 4 Tihomir Surdilovic 2013-11-25 10:24:18 EST
fixed in designer master and 6.0.x branches
Comment 5 Marek Baluch 2013-12-20 15:17:31 EST
Verified in ER6.

Note You need to log in before you can comment on or make changes to this bug.