This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 98405 - NPE Publishing a template
NPE Publishing a template
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
high Severity high
: ---
: ---
Assigned To: Justin Ross
Jon Orris
:
Depends On:
Blocks: rc0blockers
  Show dependency treegraph
 
Reported: 2003-07-02 10:03 EDT by Jon Orris
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-09 13:26:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2003-07-02 10:03:05 EDT
Description of problem:
@33139/Postgres

Create a template for the Article type
Attempt to publish the template.
Boom.

Template used:
<%@ page
    import ="com.arsdigita.cms.dispatcher.MasterPage,
com.arsdigita.dispatcher.*" %>
<h1>Snerky Snorky!</h1>

<%!
    private MasterPage myPage = new MasterPage();
%>
<b>Bold as bold is!</b>
<%

    RequestContext context = DispatcherHelper.getRequestContext(request);
    myPage.init();
    myPage.dispatch(request, response, context);
%>

Error:
-*-*-*-*-*- Begin Error Report -*-*-*-*-*-
-*-*-*- ACS Error Report Code:
goodeats.boston.redhat.com:8080:6fa512a4:f6234e4545 -*-*-*-
-*-*-*- Message: null -*-*-*-

-*-*-*- Section: HTTP headers -*-*-*-
accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg,
application/x-shockwave-flash, */*
accept-encoding: gzip, deflate
accept-language: en-us
cache-control: no-cache
connection: Keep-Alive
content-length: 1095
content-type: application/x-www-form-urlencoded
cookie: JSESSIONID=9885805ED87D386B2B373C7CE75F597A;
ad_user_login=2008!1151761744777!dSqxm12cIl/7sqxOX0drFw==
host: goodeats.boston.redhat.com:8080
referer:
http://goodeats.boston.redhat.com:8080/ccm/articles/admin/item.jsp?bbp.2112.sel=5073&bbp.1532.sel=5062&bbp.3.pane=1&bbp.295.sel=5023&bbp.491.sel=5029&bbp.2018.sel=5068&bbp.1313.sel=5052&bbp.187.sel=5018&bbp.1135.sel=5044&bbp.957.sel=5034&bbp.1053.sel=5039&bbp.v=4&bbp.s=3&item_id=7050&bbp.i=cz3g06vasnk0pe6ts3ea6mnupeszlxip9lzsfyi9g26r1bcjgk52oica30wnq7kshh1d936rkrdd59hmqihhlww5nj6jxllfllb8lehrscuk8gxw7ybw62w1wjr8x39yzh95vqxjhqq0nqjufwyw3ltqptezxn92opt60rk8w1h5wew3b3t19zte0mvyuwa7upz20a4208exxh9to4k36bok1c05fw0fy9iccwtfe2obv8gk1ra5f03c7suoc48m12g6lqdrn8bb2tlp1qv2sjut363f4cwta7vg6myytiy2pb5q8dz34w01p36y9kkhcvmw0ezrdg8w8uslj6ndy2gchsxol0stdn7jzbmr57wczpw58mm2dix74dccnvnwp3h0aoejtqa6aoxw00b0ipywl4u5mdoggxdn8w72reorsa77zrpwlv1vjrrx32p13hmepyz97g3u11h8axf2swtb7xfpyn94av7cr6cmyzvdgy7jjwlwukw&bbp.31.sel=7048&bbp.e=select&bbp.2593.d=asc&bbp.1212.sel=5047&bbp.1426.sel=5057&g11n.enc=UTF-8&bbp.2580.d=asc&bbp.112.sel=5014&bbp.2292.d=asc&g11n.enc=UTF-8
user-agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

-*-*-*- Section: Cookies -*-*-*-
JSESSIONID: 9885805ED87D386B2B373C7CE75F597A (expires: -1)
ad_user_login: 2008!1151761744777!dSqxm12cIl/7sqxOX0drFw== (expires: -1)

-*-*-*- Section: CCM User -*-*-*-
Party not logged in

-*-*-*- Section: Stack trace -*-*-*-
java.lang.NullPointerException
	at
com.arsdigita.cms.ui.lifecycle.ItemLifecycleSelectForm$FinishTaskListener.process(ItemLifecycleSelectForm.java:436)
	at com.arsdigita.bebop.FormSection.fireProcess(FormSection.java:491)
	at com.arsdigita.bebop.FormSection$4.process(FormSection.java:465)
	at com.arsdigita.bebop.FormModel.fireFormProcess(FormModel.java:478)
	at com.arsdigita.bebop.FormModel.process(FormModel.java(Compiled Code))
	at com.arsdigita.bebop.Form.process(Form.java:440)
	at com.arsdigita.bebop.Form.respond(Form.java:281)
	at com.arsdigita.bebop.PageState.respond(PageState.java:348)
	at com.arsdigita.bebop.Page.process(Page.java:695)
	at com.arsdigita.bebop.Page.process(Page.java:677)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:731)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:262)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:71)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:270)
	at org.apache.jsp.item$jsp._jspService(item$jsp.java:96)
	at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:107)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
	at
org.apache.jasper.servlet.JspServlet$JspServletWrapper.service(JspServlet.java:201)
	at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:381)
	at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:473)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
	at
org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:683)
	at
org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:431)
	at
org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:355)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardHelper(DispatcherHelper.java:174)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.java:203)
	at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.java:216)
	at
com.arsdigita.cms.dispatcher.FileDispatcher.chainedDispatch(FileDispatcher.java:61)
	at com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
	at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:134)
	at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:119)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java(Compiled Code))
	at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:113)
	at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:127)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java(Compiled Code))
	at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:102)
	at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:237)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
	at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
	at
org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:683)
	at
org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:431)
	at
org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:355)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:212)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:198)
	at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:130)
	at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:136)
	at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
	at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
	at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardContext.invoke(StandardContext.java(Compiled Code))
	at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java(Compiled Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java(Compiled
Code))
	at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java(Compiled
Code))
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java(Compiled Code))
	at
org.apache.catalina.connector.http.HttpProcessor.process(HttpProcessor.java(Compiled
Code))
	at org.apache.catalina.connector.http.HttpProcessor.run(HttpProcessor.java:1125)
	at java.lang.Thread.run(Thread.java:512)


-*-*-*- Section: Request summary -*-*-*-
Context path: 
Request URI: /ccm/articles/admin/item.jsp
Query string: null
Method: POST
Remote user: null

-*-*-*- Section: System properties -*-*-*-
catalina.base: /home/boston/jorris/webserver/jakarta-tomcat-4.0.6
catalina.home: /home/boston/jorris/webserver/jakarta-tomcat-4.0.6
catalina.useNaming: true
file.encoding: UTF-8
file.encoding.pkg: sun.io
file.separator: /
invokedviajava: 
java.assistive: ON
java.awt.fonts: 
java.awt.graphicsenv: sun.awt.X11GraphicsEnvironment
java.awt.printerjob: sun.awt.motif.PSPrinterJob
java.class.path:
/opt/IBMJava2-131/lib/tools.jar:/home/boston/jorris/webserver/jakarta-tomcat-4.0.6/ccm/WEB-INF/lib/jaas.jar:/home/boston/jorris/webserver/jakarta-tomcat-4.0.6/ccm/WEB-INF/lib/jce.jar:/home/boston/jorris/webserver/jakarta-tomcat-4.0.6/ccm/WEB-INF/lib/sunjce_provider.jar:/home/boston/jorris/webserver/jakarta-tomcat-4.0.6/ccm/WEB-INF/lib/xerces.jar:/home/boston/jorris/webserver/jakarta-tomcat-4.0.6/ccm/WEB-INF/lib/xalan.jar:/opt/apps/oracle/product/9.2.0/jdbc/lib/classes12.zip:/home/boston/jorris/webserver/jakarta-tomcat-4.0.6/bin/bootstrap.jar
java.class.version: 46.0
java.compiler: jitc
java.endorsed.dirs:
/home/boston/jorris/webserver/jakarta-tomcat-4.0.6/bin:/home/boston/jorris/webserver/jakarta-tomcat-4.0.6/common/lib
java.ext.dirs: /opt/IBMJava2-131/jre/lib/ext
java.fullversion: J2RE 1.3.1 IBM build cxia32131-20020410 (JIT enabled: jitc)
java.home: /opt/IBMJava2-131/jre
java.io.tmpdir: /home/boston/jorris/webserver/jakarta-tomcat-4.0.6/temp
java.library.path:
/opt/IBMJava2-131/jre/bin:/opt/IBMJava2-131/jre/bin/classic:/opt/apps/oracle/product/9.2.0/lib:/lib:/usr/lib:/usr/local/lib:/usr/lib
java.naming.factory.initial: org.apache.naming.java.javaURLContextFactory
java.naming.factory.url.pkgs: org.apache.naming
java.runtime.name: Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version: 1.3.1
java.specification.name: Java Platform API Specification
java.specification.vendor: Sun Microsystems Inc.
java.specification.version: 1.3
java.vendor: IBM Corporation
java.vendor.url: http://www.ibm.com/
java.vendor.url.bug: 
java.version: 1.3.1
java.vm.info: J2RE 1.3.1 IBM build cxia32131-20020410 (JIT enabled: jitc)
java.vm.name: Classic VM
java.vm.specification.name: Java Virtual Machine Specification
java.vm.specification.vendor: Sun Microsystems Inc.
java.vm.specification.version: 1.0
java.vm.vendor: IBM Corporation
java.vm.version: 1.3.1
javax.xml.parsers.DocumentBuilderFactory:
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl
javax.xml.parsers.SAXParserFactory: org.apache.xerces.jaxp.SAXParserFactoryImpl
javax.xml.transform.TransformerFactory: com.icl.saxon.TransformerFactoryImpl
line.separator: 

os.arch: x86
os.name: Linux
os.version: 2.4.20-18.8
path.separator: :
PreferredXSLTTransformer: SAXON
sun.boot.class.path:
/opt/IBMJava2-131/jre/lib/rt.jar:/opt/IBMJava2-131/jre/lib/i18n.jar:/opt/IBMJava2-131/jre/classes
sun.boot.library.path: /opt/IBMJava2-131/jre/bin
sun.io.unicode.encoding: UnicodeLittle
user.dir: /home/boston/jorris/webserver/jakarta-tomcat-4.0.6/bin
user.home: /home/boston/jorris
user.language: en
user.name: jorris
user.region: US
user.timezone: America/New_York
-*-*-*-*-*- End Error Report -*-*-*-*-*-
Comment 1 Jon Orris 2003-07-02 16:14:48 EDT
Appears to be due to a lurking lifecycle listener checking for workflow
information. As we no longer use workflow with templates, it is null.
Comment 2 Justin Ross 2003-07-07 12:31:58 EDT
Fixed in perforce 33323.  We no longer assume that items getting published have
workflows, since templates for instance do not.

Note You need to log in before you can comment on or make changes to this bug.