Bug 984069 - Appended workflow pattern missing 'A' node.
Appended workflow pattern missing 'A' node.
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity low
: ER6
: 6.0.0
Assigned To: Tihomir Surdilovic
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 12:30 EDT by Marek Baluch
Modified: 2014-08-06 16:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:12:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Added pattern (204.57 KB, image/png)
2013-07-12 12:30 EDT, Marek Baluch
no flags Details
Appended pattern. (184.27 KB, image/png)
2013-07-12 12:30 EDT, Marek Baluch
no flags Details

  None (edit)
Description Marek Baluch 2013-07-12 12:30:14 EDT
Created attachment 772819 [details]
Added pattern

Description of problem:

Appended and added workflows are not the same. Appended is always missing the first node (with label 'A'). See 'AddedPattern.png' and 'AppendedPattern.png'.


Build
DR6 (Beta5)
Comment 1 Marek Baluch 2013-07-12 12:30:49 EDT
Created attachment 772820 [details]
Appended pattern.
Comment 2 Tihomir Surdilovic 2013-11-25 11:56:19 EST
In your example the parallel split pattern is appended to a start event. In this case Designer replaces the A node (task) of the pattern with the start node which is what pattern appending does. However Designer does not update the name of the start node because it could overwrite an existing name of the start node. 

Since it seems that the simple naming (A,B,C...) causes more confusion that it helps I have removed the automatic naming of nodes on the patterns. This should fix these types of confusions.

Fix in designer master and 6.0.x branches
Comment 3 Marek Baluch 2013-12-20 15:16:46 EST
Verified on ER6.

Note You need to log in before you can comment on or make changes to this bug.