Bug 984125 - [RFE] Allow project roles to be inherited from owning domain
[RFE] Allow project roles to be inherited from owning domain
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-keystone (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: Upstream M2
: 4.0
Assigned To: Adam Young
Jeremy Agee
https://blueprints.launchpad.net/keys...
: FutureFeature
Depends On:
Blocks: RHOS40RFE
  Show dependency treegraph
 
Reported: 2013-07-12 18:13 EDT by Adam Young
Modified: 2016-04-26 17:35 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-keystone-2013.2-0.5.b2.el6ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 18:54:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 29781 None None None Never
OpenStack gerrit 35986 None None None Never

  None (edit)
Description Adam Young 2013-07-12 18:13:41 EDT
Tracking bug for upstream Blueprint. Extension will allow a domain role to imply that a user also has roles on projects in that domain.

https://blueprints.launchpad.net/keystone/+spec/inherited-domain-roles
Comment 2 Dmitri Pal 2013-07-23 17:01:19 EDT
How to test see details here:
 https://github.com/openstack/identity-api/blob/master/openstack-identity-api/v3/src/markdown/identity-api-v3-os-inherit-ext.md

This has to be tested using curl. CLI does not support it yet.
Examples are here: 
http://docs.openstack.org/developer/keystone/api_curl_examples.html
Comment 7 errata-xmlrpc 2013-12-19 18:54:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.