Bug 984141 - Wine cannot be picked for opening DOS/Windows executables in Nautilus
Wine cannot be picked for opening DOS/Windows executables in Nautilus
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-12 20:30 EDT by Jonas Thiem
Modified: 2013-09-19 10:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-14 02:55:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonas Thiem 2013-07-12 20:30:15 EDT
Description of problem:
/usr/bin/wine cannot be picked as DOS/Windows executable opener in Nautilus, which means I am forced to open exe files with a zip archiver under Gnome 3 or open up a terminal and not use Nautilus and do it myself.

I wasn't sure whether to file this against wine or nautilus, because it is kinda a mix of both that results in this behaviour I assume.

Upstream seems to suggest as of here https://bugzilla.gnome.org/show_bug.cgi?id=650284 that the proper solution is a .desktop file for all applications the user might want to use with a file, hence maybe /usr/bin/wine installation should include a desktop file?
(in which case this is a wine packaging bug I suppose)

Another possile solution would be to either convince upstream to create a more sane "Open With" dialog or to patch it manually for Fedora. This would also solve this issue not only for wine as in this specific bug report, but also other programs like mplayer which might be installed without a .desktop file.
(in which case this is a nautilus bug)

Version-Release number of selected component (if applicable):
wine-1.6-rc2
GNOME nautilus 3.8.2

How reproducible:
100%

Steps to Reproduce:
1. Install a fresh Fedora 19 with Gnome 3
2. Install wine
3. Open nautilus, go into the file properties dialog and the "Open With" tab, and attempt to pick wine to open that file

Actual results:
There is no way to make wine open that file

Expected results:
wine is either listed or already the default from the point of the installation

Additional info:
Making Nautilus search the internet makes it suggest qt4wine which I suppose would also have a desktop file.

But qt4wine is not exactly the nicest graphical interface ever and frankly just an annoyance if a user doesn't care much about using different wine prefixes (perfectly valid if only using a few selected, unproblematic windows programs), since all it does is introduce more buttons to click before you get to the actual program you wanted to launch.

So qt4wine instead of wine directly is not really a nice solution for this bug.
Comment 1 Andreas Bierfert 2013-07-14 02:55:20 EDT
Wine already contains a desktop file for the purpose of registering mime types with window managers (see wine-desktop package; e.g. wine.desktop:
MimeType=application/x-ms-dos-executable;application/x-msi;application/x-ms-shortcut;).

Whatever the wm does with the information is up to the wm and not wine.

So please check of you have the wine-desktop package installed (should be the case if you install the wine meta package). If nautilus ignores this information it is a bug/missing feature in nautilus.

Note You need to log in before you can comment on or make changes to this bug.